Title / Thread Starter Last Post ByReverse Sort Order Replies Views
Garry

THIS ISN'T THE FORUM FOR LUA SCRIPTING HELP

Post your Lua scripting help threads in the Developer Discussion forum.

5th March 2013
by garry Go to last post
0 12,570
Garry

Garry's Mod Support & Help (READ THIS BEFORE MAKING A THREAD). Make your thread titles DESCRIPTIVE. "HELP" is not a descriptive thread title

We have a support site now. It contains a few articles that might help you out - so you should give it a read. http://support.facepunchstudios.com/ If you have a problem, make sure it hasn't already been addressed in the next version by looking at...

30th October 2012
by garry Go to last post
0 21,959
Help

certain doors have a weird texture

certain doors look like this: help?

3 Hours Ago
by cowslaw Go to last post
0 39
Help

Server Laggs while Shooting

My Server gets mass Laggs when someone is shooting at someone... It only Laggs when you hit the enemy and thas massly... Intel(R) Xeon(R) CPU E5-2667 v4 @ 3.20GHz (32 Cores) RAM: 10GB Gamemode DarkRP

4 Hours Ago
by code_gs Go to last post
7 130
Help

Facepunch! Engine Error fix please?

I've tried just about everything to fix it. I did the factory reset, I've tried insane amounts of fixes. I've tried everything accept factory resetting my computer itself, my friends play it a lot and I can't join in on the fun. I've been looking for a...

4 Hours Ago
by Blitzerin Go to last post
0 45
Help

(TDM) Cars are lagging back

hey guys on my server the tdm cars are lagging all time back, i have 91 addons in the collection and only 5 bought addons server specs : 6cpu vcores 24 gb ram 2 x 2TB SATA / 2 x 240 GB SSD Traffic flatrate : 1.000 MBit

9 Hours Ago
by code_gs Go to last post
12 108
Help

Spawning as unassigned, in building, tried everything I could think of no luck

I am restarting my server and everything was going fine until today when I installed the backed up addons I used with this server before. I am lost because I am not sure if it is the jobs.lua or an addon because there is no lua error or anything. I also...

9 Hours Ago
by xStylo27 Go to last post
6 194
Help

Default category's not deleted.

So basically I made new category's for the tool tab. VIP Tools and Admin tools. I deleted all of the tools out of constraints, render and poser. The category's are still there with nothing in them. How do I remove these. 1st December 2016 I just...

11 Hours Ago
by dementedrock Go to last post
10 225
Help

My models are static...

So my problem is that the models I have used are static they are shaped with their arms out and legs square to the shoulders. They don't perform any animations like walking, running, jumping, etc. The pastebin of my models jobs:...

11 Hours Ago
by dementedrock Go to last post
2 82
Stupid

solved What are the positives/Negatives of sv_download 1 and upload?

I was just curious as I want to enable sprays onto our server. Is there anything negative that could happen by enabling this? They are currently both set to 0

19 Hours Ago
by fappymcfap Go to last post
2 118
Question

Disabling automatic brightness balance?

As you might know, Gmod has this setting where brightness will automatically correct itself if you look at something really bright, darkening everything. And likewise the other way around if you're in complete darkness. In theory, it's a great idea,...

1 Day Ago
by Robotboy655 Go to last post
1 93
Help

[ERROR] RunString:2: unexpected symbol near '<' 1. unknown - RunString:0

When I load my server it says "Something's creating script errors" and when I look at the console it says " RunString:2: unexpected symbol near '<' 1. unknown - RunString:0" 3rd December 2016 BTW I think the error is in settings.lua as I've...

1 Day Ago
by code_gs Go to last post
5 166
Help

Rust

When i try to join a Rust server I always get a error that's saying ISteamUGC_ptr is null and i want it fixed asap cause would love to play the game with friends :smile: would show you a pic with the error but i don't know how :/ (User was banned...

1 Day Ago
by elixwhitetail Go to last post
2 102
Help

Player not being released from jail even though jail time is over [POLICE]

DarkRP settings.lua are fine. GM.Config.telefromjail = true -- teletojail - Enable/disable teleporting to jail. GM.Config.teletojail = true I've googled for hours but I didn't find a solution so I really don't...

1 Day Ago
by NeonSide Go to last post
6 222
Help

Blue screen in Garrys mod

Hello all hwo reading it.I launching gmod next blue schreen and word loading. And game crash. Please help me!

1 Day Ago
by sans ppap Go to last post
0 70
Help

Hammer texture script lua

Hello , I have a question , Is it possible to change texture of a map via a script because I have a problem with a brush that's black color on the map and we can't decompile the map for fix it. Best Regards , Proxene

1 Day Ago
by proxene Go to last post
0 61
Help

solved Fix NPC [Lua]

Hello I have a little problem :) When I create a NPC my NPC stay in T position. How to fix it ? Thanks in advance Best Regards, Proxene

1 Day Ago
by proxene Go to last post
2 135
Help

Tracking Traitor weapon usage

Is there such a thing that exists? If not, how would I go about doing that.

2 Days Ago
by fappymcfap Go to last post
0 65
Help

Stuck on "Fetching Addons" at GMOD startup.

The workshop download UI in the game hangs up at startup and freezes into a non-responsive state when I start up the game. I have unsubbed to everything and it worked again, redownloaded a small amount of 60 addons and then it gets stuck into a...

2 Days Ago
by RasmusG5 Go to last post
4 179
Question

SetupDataTables() on game.GetWorld()

When can you call SetupDataTables on the worldspawn entity? Players are a bit easier since you can just local PLAYER = FindMetaTable("Player") function PLAYER:SetupDataTables() self:NetworkVar( "Entity", 0, "Zone" ) self:NetworkVar( "String",...

3 Days Ago
by Revenge282 Go to last post
4 99
Help

When I hold weapons fps drops.

Hello, when i hold weapons fps drops to 10-30. When i hold camera fps 70-120. Where is the problem?

3 Days Ago
by invincible132 Go to last post
3 147
Help

GMod Addons not showing up on Sandbox?

I have loads and loads of addons installed. I even reinstalled them manually and deleted them from the addons folder in my garrysmod folder. Despite that, they still do not show up in my Q menu. Yes, I did check the Facepunch Support site and my date and...

3 Days Ago
by RandomPerson15 Go to last post
2 115
Help

gmpublish Problems/ question

Hey. Sorry for my english :) Is it possible to load the 305-megabyte file in the workshop steam? For example: the description of the addon http://steamcommunity.com/sharedfiles/filedetails/?id=336509414 file size of 51,592 megabytes specified. If you...

3 Days Ago
by Kutter Go to last post
4 133
Computers

Broken .dupe & .gms Files

Hello, I recently ran into a problem with my dupe files and Save files. Whenever I try to access my dupes or save in game the pictures are just a gray photo, and neither will do anything, if I click deploy with the dupes nothing happens, and if I click...

3 Days Ago
by Robotboy655 Go to last post
7 203
Help

solved Gmod TTT Server Crash

Hi, I think this may be a bug with GMod due to it being a C++ problem rather than a Lua problem. Anyway, anytime I try and change the map, my server console will either freeze and I have to press the up arrow key for it to close or it just closes by...

4 Days Ago
by Unknown Gamer Go to last post
2 113
Question

solved Weird situation

Hello, Yesterday I had weird situation. I was playing on some random server and everything was ok. But then, my Garry's mod went full black-screen. I couldn't see anything, thought it was graphics card or something. To my surprise, I could alt tab and...

5 Days Ago
by Hongiss Go to last post
4 108
Help

solved map is missing ERROR

my map is 122 mb (rp_world_kdg ) ,how to solve this error ?

5 Days Ago
by eligrand1 Go to last post
8 118
Question

solved I need Help with my hud

Please Remove This Thread

5 Days Ago
by xander1998 Go to last post
0 85
Help

npc_floor_turret doesn't SelfDestruct - Falls over and pops up

Mods: Mislabeled the title, "npc_turret_floor", if you could fix it. I had a Lua code that once was working, and now it is not. I tested the problem to ensure it wasn't my code, and I could recreate the problem in both TTT and Sandbox. Here's the...

5 Days Ago
by Rory Go to last post
4 188
Help

Missing bullet Textures

So when im playing DarkRp ttt or sandbox the M9K weapons and Css weapons bullet shells are purple and black i have all of the Valve games needed for Gmod expect Hl2 Ep1 all the others are mounted and verifyed ive tryed reinstalling them and deleting the...

5 Days Ago
by code_gs Go to last post
8 125
Help

solved Game Crash from Access Violation

Alright so there's a gamemode called Ground Control as seen here (gamemode on GitLab) and everytime the round restarts or ends, or more specifically when it tries to read files locally, the game will crash. I've seen others that have had this issue...

6 Days Ago
by Dementei Go to last post
2 131
Help

Server Category is gone.

EDIT: Interestingly enough, out of no where, the category just popped up. Thanks anyways lol. Hey there. Recently, after logging onto Garry's Mod, I've noticed that our server's category, (And prob other servers since I cannot even find the...

6 Days Ago
by {IMFR} Frost Go to last post
0 104
Help

Material Problems on a Server

Hi there, I play on a garry's mod server and the administrators on that server were not able to assist me and advised me to ask here. Here is my problem: Here are some screenshots: http://imgur.com/a/tiONU...

6 Days Ago
by kix2468 Go to last post
3 135
Question

solved Do maps download to clients by simply putting them in the maps folder?

This is a really stupid question and I'm probably an idiot for asking but eh. So currently, I have all the maps on our server to download via workshop, I'm not sure if they download it all in one go. What I mean by this is if a new player joins,...

1 Week Ago
by fappymcfap Go to last post
4 145
Help

Server is lagging with 17+ users..

hey my server is lagging when there are over 17+ users. heres my start cmd : screen sh ./srcds_run -console -maxplayers 64 -game garrysmod +gamemode darkrp +map rp_downtown_v4c_v2 +r_hunkalloclightmaps 0 heres my server.cfg hostname "NO"...

1 Week Ago
by code_gs Go to last post
10 261
Help

Black Screen on exit

Hello, I have had an issue with GMod that only happens on exit. The game will run perfectly fine during my playing session, no issues, bugs, glitches, not even the mods I use have issues. When I exit Gmod, all my monitors go black and I can't do...

1 Week Ago
by Capn'Robm Go to last post
0 105
Help

solved My game keeps crashing when joining server

Edit* Nevermind, the issue still continues... This crashes my game weapons/arms/v_arms_gambler_new.mdl needs to be recompiled Any help? Please.

1 Week Ago
by fappymcfap Go to last post
2 176
Help

solved Bone manipulation - how does this work?

Hello facepunch, I'm wondering if someone could help me, I've been trying to find out how I can edit bones on a specific client. By press E on the client he should put his hands behind his back, could someone help me on where and what functions is...

1 Week Ago
by Chickengbs Go to last post
2 155
Help

No steam user

So when trying to run a map gmod comes up then says no steam user

1 Week Ago
by Battlefan1942 Go to last post
4 176
Help

(D)DoS Attack Disguising Itself As Legitimate Traffic

Hello, recently my Garry’s Mod server has been getting hit by (D)DoS attacks. My host automatically filters out a majority of the attacks we receive. But unfortunately, these attacks are aimed at a flaw in the Source Engine (the flaw has to do with how...

1 Week Ago
by iamgoofball Go to last post
3 300
Help

Mouse settings really messed up and i cant do anything after trying to reset to defaults

Hello, so recently my Gmod started acting up and its never done this before after hours of searching trying to find the problem on my own and doing many other things i'm stumped on this every time i log into gmod my mouse sensitivity is high when I turn...

1 Week Ago
by Larrybug Go to last post
3 111
Help

Light works on servers, not on my singleplayer game though.

When I spawn a gmod_light entity, it doesn't light up. The entity spawns, but it doesnt emit light. On a multiplayer server it works properly. It could be a console command setting or an addon I installed, but idk.

1 Week Ago
by Winter Go to last post
1 128
Help

Extreme Server Lag

Hey all, I'm currently running a Clone wars server on a dedicated server running Windows Server 2012 R2, at some points the server get's really really laggy, on srcds.exe the frames drop to 12-15 fps once there are about 20-25 people on. Here is my...

1 Week Ago
by KayKayy Go to last post
4 358
Steam

Can't upload Adv. Dupes to workshop?

Recently i made an awesome dupe that involves constraints and entities that wouldnt dupe correctly via the vanilla duplicator, but it would with the adv duplicator (from the workshop). I've gone through all the tutorials about uploading a workshop addon,...

1 Week Ago
by Robotboy655 Go to last post
1 120
Help

kill command not working on my darkrp server

hey guys for some reason the kill command on my darkrp server isnt working, and im pretty sure i didnt disable it.

1 Week Ago
by mcNuggets1 Go to last post
1 196
Help

FAdmin - how can i view who is ranked?

Hi, i have a big problem when i have to unranked a moderator i unrank him from ULX but i can't unrank him from FAdmin if he isn't connected to the server. How can i view all player which are ranked with fadmin and how can i unrank them?

1 Week Ago
by Benjii Go to last post
14 603
Help

Darkrp This Shipment is Unavailable.

I tried creating some new shipments in DarkRP, but when I added them to my server, I got a "This shipment is unavailable." message when trying to buy from the correct job, then once I reverted, none of my shipments worked, and displayed the same message....

1 Week Ago
by bmeeker625 Go to last post
0 126
Help

Custom Job model errors in my server for players

My custom job models works for me and players who only SUBSCRIBED to those addons but won't work for players who aren't subscribed to those addons. :( +host_workshop_collection x -authkey x done. BTW I am using a hosting website to run this server...

1 Week Ago
by NeonSide Go to last post
12 309
Question

Hostname question

How some servers got custom characters hostname like λ,★ ◥⊙▲ and etc

1 Week Ago
by eprom33 Go to last post
4 274
Help

Sandbox HUD in DarkRP HUD

Im running darkrp and I have a custom hud. The default, sandbox hud is still behind it although, which is pretty annoying, any way to remove it?

1 Week Ago
by YoutoYokodera Go to last post
2 156
Help

Garry's Mod not loading addons ( 2 3 4 Last )

It seems now that gmod isn't loading certain addons, both workshop and legacy. This just started today, yesterday everything was fine. Workshop subscriptions addons folder However in game most of these don't show up. Servers with the addons I...

Gnomical Thread has images Agree x 29
1 Week Ago
by SourceLambda Go to last post
123 41,521
Help

Rendering issue

Whenever I join my friend's server, I have a problem with my rendering. I can't even describe what happens Extra info(if it helps): I am running the latest version of Gmod on Windows 10 64 bit system. I have tried a complete re-install of...

1 Week Ago
by Jck123 Go to last post
2 171
Help

CSS Won't Mount

Welp I've tried just about everything and I'm bamboozled. CSS wont mount at all. Heres my mount.cfg heres where my cstrike folder is I've re-installed cstrike, I've made a .txt file called mountdepots.txt and tried using that, and I've put...

1 Week Ago
by Hexical_ Go to last post
2 165
Help

solved How do I make a gamemode?

I wanna make one for a friend, to make him laugh

1 Week Ago
by MrBunneh Go to last post
1 150
Help

Pointshop Equiping Problem

So there are these two posts regarding the same issue... https://github.com/adamdburton/pointshop/issues/267 and https://github.com/Arizard/deathrun/issues/98 Those two users are also using Arizard Deathrun Neue and we have the same problem which is...

1 Week Ago
by supermonkey89 Go to last post
0 132
Repeat

I Have a Problem with too many errors when the Server starts.

Whenever I start the server, he spins the console with eg: KeyValuesError: LoadFromBuffer: missing {in fileMaterials / models / props / vidscreen01a.vmt (* VertexLitGeneric *), (* proxies *), (* TextureScroll *), KeyValuesError: LoadFromBuffer:...

1 Week Ago
by Marco1702 Go to last post
4 225
Help

NPCs not spawning with weapons!

So I get these errors in console and the npcs only spawn with stun sticks. Bad sequence (-1 out of 160 max) in GetSequenceLinearMotion() for model 'Combine_Soldier_PrisonGuard.mdl'! Bad sequence (-1 out of 160 max) in GetSequenceLinearMotion() for...

1 Week Ago
by Hackcraft Go to last post
0 140
Help

Crash issue on my mac computer.

Hello, I have been experiencing crashes for about 4 years now on my iMac (21.5-inch, Late 2012). The common crash that I have been getting is, I log into a darkrp server then I can get about 10-30 minutes of gameplay in then suddenly it crashes! ...

1 Week Ago
by Tim_27 Go to last post
0 156
Help

Segmentation Fault on Ubuntu 14.04

This message was posted as my server crashed. Crazy origin on entity Origin: Angles: Velocity: Angular Velocity: Defusing! Segmentation fault (core dumped)

2 Weeks Ago
by Sys32 Go to last post
4 200
Help

solved [Crash] my friends crash ony my server

Dear Everybody, I need help from the developers. Here is the crash dump Link I hope it will help you to get info why they crash than I can fix it.

2 Weeks Ago
by kem008 Go to last post
2 153
Help

DarkRP server categories wont work

so i have correctly coded categories in http://pastebin.com/MiF8DybB for the code but it shows this error when i join There is 1 Lua problem! Please check your console for more information! A runtime error has occurred in "your jobs" on line -1....

2 Weeks Ago
by TheRedPirate Go to last post
3 151
Help

Not spawning into server.

Every time i join a server, it stays on the loading screen but has the MOTD, Gmod thinks i have loaded in but i am still on the spawn menu. Please help, it is happening to every server i join.

2 Weeks Ago
by Hazzar10 Go to last post
0 156
Lua

Experience Fuction SWEP error

Hey We have a star wars RP server and we have a lightsaber force power that gives experience but soon as more then one person starts meditating it stops giving exp if self.Owner:KeyPressed(IN_ATTACK2) then local level = tonumber(...

2 Weeks Ago
by jcsc123456 Go to last post
10 262
Help

TTT Post round bug (Bodies)

Hi, after the round ends, sometimes the post round menu says something along the lines of "Player" identified (Absurd number) bodies and awards them anywhere from 50-90 points. I've searched this forum and a few others but haven't found any reports/fixes...

2 Weeks Ago
by Voxtria Go to last post
7 351
Steam

Unsubscribing all add-ons

Is there any way to unsubscribe to every add-on I have subbed on the workshop?

2 Weeks Ago
by Flashlight Go to last post
3 181
Help

Workshop content not loading properly.

Alright here's the deal. I subscribe to the workshop collection in question, and i check how it's loading. It's shown to have instantly been downloaded which is bogus because i don't have the internet to download 1.4 gigs in a few seconds. When i...

2 Weeks Ago
by Robotboy655 Go to last post
13 261
Question

How to correctly setup people to download my maps?

Hello, just created an account here, hope to learn with you guys. So I'm hosting a TTT gmod server from my computer and I just can't understand if I'm setting up maps for people download correctly. - I created a collection and placed my maps there,...

2 Weeks Ago
by mijyuoon Go to last post
1 165
Help

inventory ulx usergroup function [what is wrong?]

hey guys, ive got a inventory system and with this command in the inventory.lua i can set how many guns you can pickup. with this line local maxguns = CreateConVar( "drp_maxguns", "4", { FCVAR_REPLICATED, FCVAR_ARCHIVE } ) now i tried to do a...

2 Weeks Ago
by schlossrick Go to last post
0 136
Help

No mouse cursor on startup

Hello all. Every time I try and startup garry's mod, there is no mouse cursor. This happens even when I eventually join a server and want to spawn props. Please help me out.

2 Weeks Ago
by Hazzar10 Go to last post
0 156
Help

Resolution changes for no reason (Garry's mod)

I've been having a problem for a few months where my resolution changes for no reason. My standard resolution is at 1920 x 1080 (native) and it changes to 1280 x 720 and then my game continues to have lag spikes, roughly every minute if not more. I...

2 Weeks Ago
by BananaFish0x0 Go to last post
0 174
Help

solved Pointshop How to make spec not get points?

Like the title says how can i make it so spec in ttt can not gain points while alive/dead can. The problem i'm having isSpec() counts dead people as spec if PS.Config.PointsOverTime then timer.Create('PS_PointsOverTime_' .. self:UniqueID(),...

2 Weeks Ago
by redfox1 Go to last post
2 169
Rant

hackers

#mod move to rust forums plz you need to get your shet togather with theses moscow 7 hacker and ban them on rust or ill start hacking i got the money to buy rust for a life time so ether get to work or i well (User was banned for this post ("Wrong...

2 Weeks Ago
by rednite101 Go to last post
0 229
Help

Console Errors with fonts

For some reason I keep getting this error in my console about fonts. When you join the server shows it downloads but I'm still confused why this error comes up. I honestly don't even know what addon I have that USES those fonts. For the server I placed...

2 Weeks Ago
by ChocolateX3 Go to last post
0 164
Help

Map Sound Issue on DS

Hello, I finally got Episode 2 mounted onto my server correctly, however I am still having a weird sound issue playing in certain parts of the map. The map in question is Sgt. Sickness' V4B1 and his recently released EvoCity 2 V5P. Whenever a player...

2 Weeks Ago
by TheSenDest Go to last post
3 211
Help

Games crash when join this server!

So, when I join one server my game crashes but I hear the game sound. This is the IP for the server 185.38.149.17:27045. I have reinstalled my game and deleted all the addons but it didn't work. When I reinstalled my game it works once then kept...

2 Weeks Ago
by xjokerx9 Go to last post
2 197
Question

A Question Regarding spawnicons & icon16

I've tried to create a spawn menu with a custom icon and place the icon into the icon16 located in materials, but Garry's Mod refuses to mount the icon16 folder if it's packed into a workshop addon, packed into an external vpk or placed in the addons...

2 Weeks Ago
by karbz971 Go to last post
0 176
Help

Graphics on garry's mod blurrier/worse

About 1 and a half month ago I stopped playing garry's mod as much as I use to and I started playing rust more, I had some fps problems in rust so I decided to go on youtube for help, I found a video that helped me but I had to download some programs and...

2 Weeks Ago
by courage_mk Go to last post
6 284
Help

Pointshop (Undefined reskin by RocketMania) Problem

While scrolling through my pointshop earlier I noticed this happening ; https://gyazo.com/4a97853e621f2b0a6d0376c9451ede8d It continually flickers throughout almost all of my items like that and I can't find anything wrong w/ the code or models.

2 Weeks Ago
by Hitosherizu Go to last post
0 193
Help

Starwarsrp server crashing on map change with new host

So I just recently change to a new host and whenever I go to change the map for a starwars event it crashes and resets back to the default map. Our workshop is quite large due to it being starwarsrp here is a link...

2 Weeks Ago
by xjokerx9 Go to last post
1 199
Help

I need help i have been hacked.

Hello, my name is Zaros So today i went on my server that i've made but the moment i went in it redirected me to another server. I thought it was weird so i rejoined again and it happend once more. I decided to create a new account and join it and...

2 Weeks Ago
by Obey_ Go to last post
7 423
Help

HELP PLEASE

I am in my custom Garry's Mod server and am reviving messages saying "Your Garry's Mod has been hacked! Please contact the developers" and "u have been hacked, once again". If anyone has any idea what this is please let me know ASAP as I am very...

2 Weeks Ago
by mijyuoon Go to last post
6 254
Help

Dark RP Jobs error?

Hi, I've got an error could somebody help me please? I get this when attempting to join my server addons/darkrpmodification-master/lua/darkrp_customthings/jobs.lua:232: table index is nil 1. unknown -...

2 Weeks Ago
by Obey_ Go to last post
8 868

Users Browsing this Forum
  1. Elcard100
(20 guests)