1. Post #1
    Gold Member

    February 2009
    2,339 Posts
    I updated BF2 with patch 1.41 with no hitch, but for the new 1.5 patch I hit run, this comes up, I hit allow, and it dissapears. Nothing else, no matter how long I wait. This has happened before in the past on vista if I recall, but I never got a fix. I think I just woke up one day, retried it, and it worked.




    If anyone knows how to fix this problem, it would be lovely.

  2. Post #2
    Plastical's Avatar
    August 2009
    583 Posts
    Weird, the setup does work for me, although it does take a long time for it to load (about 2-3 minutes for me on my machine).

  3. Post #3
    Ubercharged's Avatar
    August 2008
    891 Posts
    Mine takes about 15 minute to load and then dosnt install, but instead says " cannot locate install folder"


    (on vista)

  4. Post #4
    Gold Member

    February 2009
    2,339 Posts
    Gosh darn it. Their patches are horrible, and they offer no insight on how to solve the installer problems.

  5. Post #5
    Gold Member
    Dennab
    June 2009
    6,496 Posts
    Doesn't really matter until they update Punkbuster, does it? Have you tried right-click Opening it or using the command line?
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  6. Post #6
    Gold Member

    February 2009
    2,339 Posts
    Haven't tried command line, I'm not quite sure how to do it, and right-click opening doesn't work either.

    Also, BF2 is currently working for most people w/ windows 7, including myself on 1.41.

  7. Post #7
    Gold Member
    YodaEXE's Avatar
    December 2005
    1,473 Posts
    Haven't tried command line, I'm not quite sure how to do it, and right-click opening doesn't work either.

    Also, BF2 is currently working for most people w/ windows 7, including myself on 1.41.
    Try running it as an administrator, and maybe setting compatibility mode to Vista or something. That seems to solve most problems.

  8. Post #8
    Black0ut's Avatar
    June 2008
    1,060 Posts
    Make sure you've actually download it completely. I know with me, it download 1.3GB then the connection got interrupted, resulting in the download stopping and giving me the impression it had finished. When I tried to run it, it just did nothing(like what you're explaining). Although I didn't get the UAC prompt as I have it disabled.

  9. Post #9
    Gold Member
    bassie12's Avatar
    July 2005
    1,733 Posts
    Patch worked fine for me on W7.
    Punkbuster also works fine as it can be.

    So either yours got corrupted or you are doing something wrong.
    Didn't you need to have 1.41 installed before this one?

  10. Post #10
    Plastical's Avatar
    August 2009
    583 Posts
    Yeah patch 1.41 needs to be installed before patch 1.5.