1. Post #1
    Gold Member
    ddsn's Avatar
    August 2006
    2,374 Posts
    When I play, and I play for about, 5-10 minutes, I have a problem where I cant see one of the players. I just walk in a empty room, and I don't see anyone, then I get killed. Help me please. :c

  2. Post #2
    Gold Member
    Campin Carl's Avatar
    October 2006
    5,235 Posts
    HAX
    caps

    Edited:

    If you use custom skins they might go invisible due to switching to a sv_pure 1 server

  3. Post #3
    Gold Member
    DuncanFrost's Avatar
    August 2007
    13,888 Posts
    It's a bug related to alt+tabbing and/or lagspikes. When they kill you, does the deathcam show them in another part of the map entirely? If so, yeah, it's that bug. You have to reconnect to fix it.

    If you often alt+tab and you want to get a fix, put '-windowed -noborder' into the launch options of your TF2.

  4. Post #4
    Selek's Avatar
    July 2007
    1,016 Posts
    Do you happen to alt-tab or minimize during the game?

    Edit: Ninja'd

  5. Post #5

    July 2009
    84 Posts
    They're probably cloaked spies?

  6. Post #6
    Trooth's Avatar
    December 2007
    133 Posts
    I was on the other end of this situation once. I was a soldier, and I saw an enemy heavy, wondered why he didn't shoot me, and I walked up and shoveled him to death. When he died, he was like "wtf? Invisible soldier? Great, I thought this server banned hackers."

  7. Post #7
    Jvs
    PENISCorp's First Employee
    Jvs's Avatar
    June 2009
    1,568 Posts
    It's a bug related to alt+tabbing and/or lagspikes. When they kill you, does the deathcam show them in another part of the map entirely? If so, yeah, it's that bug. You have to reconnect to fix it.

    If you often alt+tab and you want to get a fix, put '-windowed -noborder' into the launch options of your TF2.
    Or just wait for someone to kill them,they respawn and you can see them.
    Unless it's a sniper...

  8. Post #8
    Gold Member
    Sibilantjoe's Avatar
    May 2007
    1,818 Posts
    It's a problem related to alt-tabbing, reconnect to fix.

  9. Post #9
    You'll have to speak up. I'm wearing a towel.
    omfgnex's Avatar
    January 2007
    762 Posts
    Yeah it's happened to me before, really annoying

    Also, 1,000 :keke:

  10. Post #10

    September 2008
    302 Posts
    When it happens, type record a in console then type stop, it will reload everything, you don't have to reconnect or reinstall your game.

    And to fix the problem, find the source of lagspikes/stuttering.

  11. Post #11
    World toilet roll stacker champion 2012
    Bemon's Avatar
    August 2006
    232 Posts
    Type in the console "Record (Something)", then straight after type "Stop" this fixes the invisible people for me

  12. Post #12
    Gold Member
    ddsn's Avatar
    August 2006
    2,374 Posts
    Alright thanks guys.

  13. Post #13
    Gold Member
    DementNeo's Avatar
    April 2006
    3,485 Posts
    When it happens, type record a in console then type stop, it will reload everything, you don't have to reconnect or reinstall your game.

    And to fix the problem, find the source of lagspikes/stuttering.
    Better to bind it to F6 or something

    bind F6 "record demofix; stop"

    Might need a wait command in there too, but I doubt it

  14. Post #14

    September 2008
    302 Posts
    Better to bind it to F6 or something

    bind F6 "record demofix; stop"

    Might need a wait command in there too, but I doubt it
    A wait command isn't needed. That should work perfectly.

  15. Post #15
    NotMeh works out at home.
    Perfumly's Avatar
    June 2009
    12,103 Posts
    They're probably cloaked spies?
    r8'd []

  16. Post #16
    Keke_ke's Avatar
    February 2008
    221 Posts
    I see dead people

  17. Post #17
    Gold Member
    Tyler72493's Avatar
    March 2008
    1,328 Posts
    Phew, when I saw this topic I thought I was in General Discussion. Okay, good.

    Uhm, about your problem, I see it's been answered.