1. Post #41
    Gold Member
    Spacetech's Avatar
    January 2006
    510 Posts
    MythBuster posted:
    Space can you fix the gamemodes folder in the spacebuild svn so it is
    Code:
     gamemodes and not gamemode
    so that it will load up
    Did you even try to checkout?
    Make a folder called spacebuild2 in your gamemodes folder and right click the spacebuild2 folder and checkout to the svn url.
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  2. Post #42
    MythBuster's Avatar
    August 2007
    57 Posts
    Change it from addon format then or fix the gamemodes type in the svn because alot of people are having the same problem

    and stop making me out as a fucking moron and just fix it without making excuses to not fix it

  3. Post #43
    Gold Member
    tad2020's Avatar
    December 2006
    163 Posts
    MythBuster posted:
    Space can you fix the gamemodes folder in the spacebuild svn so it is
    Code:
     gamemodes and not gamemode
    so that it will load up
    Wrong thread.

  4. Post #44
    MythBuster's Avatar
    August 2007
    57 Posts
    Wrong thread because the people are not listening in the right one and i get morons posting there

  5. Post #45
    Gold Member
    Spacetech's Avatar
    January 2006
    510 Posts
    MythBuster posted:
    Wrong thread because the people are not listening in the right one and i get morons posting there
    Can't help you if your in the wrong thread
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  6. Post #46
    TotalMark's Avatar
    September 2007
    8 Posts
    Is it just me, or is the link broken? All I'm getting is the picture when I click on it.

    Do I have to SVN this or something?

  7. Post #47
    Gold Member
    Spacetech's Avatar
    January 2006
    510 Posts
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  8. Post #48
    TotalMark's Avatar
    September 2007
    8 Posts
    Okay, thank you.

  9. Post #49
    Gold Member
    tad2020's Avatar
    December 2006
    163 Posts
    TotalMark posted:
    Is it just me, or is the link broken? All I'm getting is the picture when I click on it.

    Do I have to SVN this or something?
    Fixed, gmod.org links don't seem to work when they're in a quote block.

  10. Post #50
    Roktarok's Avatar
    July 2007
    236 Posts
    Hi, I don't see the terraformer tool in the tool list, Any suggestions? also i'm not sure wat the terraformer is supposed to do, could any one explain?

  11. Post #51
    PuddlePirate's Avatar
    June 2007
    98 Posts
    A request for the next version, A one way valve.

  12. Post #52
    kevkev's Avatar
    April 2007
    1,093 Posts
    PuddlePirate posted:
    A request for the next version, A one way valve.
    You mean a pump?

  13. Post #53
    PuddlePirate's Avatar
    June 2007
    98 Posts
    yeah, but without making 2 supply connectors and connecting them. Just a cutoff valve with a pump and instead of open and close make it (Off, Pump <-, and Pump ->)

  14. Post #54
    ThePlague2's Avatar
    August 2007
    43 Posts
    Yes! It's finally there. Thank you!

  15. Post #55
    Gold Member
    Spacetech's Avatar
    January 2006
    510 Posts
    Roktarok posted:
    Hi, I don't see the terraformer tool in the tool list, Any suggestions? also i'm not sure wat the terraformer is supposed to do, could any one explain?
    Terra former is a life support thing. It's supposed to make any planet earth like so its livable. It requires the asteroid mod but it's not out yet so..
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  16. Post #56
    Gold Member
    Xera's Avatar
    November 2006
    3,097 Posts
    There's an error in base_rd_entity.

    function ENT:OnTakeDamage(DmgInfo)//should make the damage go to the shield if the shield is installed(CDS)
    	if ent.Shield then
    		ent.Shield:ShieldDamage(DmgInfo:GetDamage())
    		CDS_ShieldImpact(self.Entity:GetPos())
    		return
    	end
    	DamageLS(self, DmgInfo:GetDamage())
    end
    

    ent is not being defined.

  17. Post #57
    Fabulous Vailglorous Extraordinaire
    Haxxer's Avatar
    February 2007
    10,706 Posts
    This is great. I'll have to....





    :siren: :freeman: RAVE! :siren:

  18. Post #58
    SB2DevTeam's Avatar
    September 2007
    384 Posts
    Xera posted:
    There's an error in base_rd_entity.

    function ENT:OnTakeDamage(DmgInfo)//should make the damage go to the shield if the shield is installed(CDS)
    	if ent.Shield then
    		ent.Shield:ShieldDamage(DmgInfo:GetDamage())
    		CDS_ShieldImpact(self.Entity:GetPos())
    		return
    	end
    	DamageLS(self, DmgInfo:GetDamage())
    end
    

    ent is not being defined.
    That has already been fixed yesterday, so it will be in the next update.

  19. Post #59
    Gold Member
    tad2020's Avatar
    December 2006
    163 Posts
    Roktarok posted:
    Hi, I don't see the terraformer tool in the tool list, Any suggestions? also i'm not sure wat the terraformer is supposed to do, could any one explain?
    Goto LS2 thread: http://forums.facepunchstudios.com/s...d.php?t=425099

  20. Post #60
    Gold Member
    mankind_me's Avatar
    August 2007
    6,299 Posts
    Terraformer isn't released yet.

    Edit:

    It was part of the Asteroids mod.

  21. Post #61
    PuddlePirate's Avatar
    June 2007
    98 Posts
    You can tweak the Terraformer in the file so that you can spawn and use it like I did on my server :D

    *Worships the Time Lords Science Storage Vessel*

  22. Post #62
    Roktarok's Avatar
    July 2007
    236 Posts
    Ah, thanks for the help , i was starting to go nuts trying to find it :P

  23. Post #63
    SB2DevTeam's Avatar
    September 2007
    384 Posts
    PuddlePirate posted:
    You can tweak the Terraformer in the file so that you can spawn and use it like I did on my server :D

    *Worships the Time Lords Science Storage Vessel*
    Yea the terraformer code is already included in LS2, it's just not showing up in the list, but is there already for other devs to see how it works.

  24. Post #64
    Roktarok's Avatar
    July 2007
    236 Posts
    But you can't mine terrajuice so there's not really much use for it right?

  25. Post #65
    PuddlePirate's Avatar
    June 2007
    98 Posts
    Correct, But if you know some lua you can whip up a ent that creates the juice, something like to the oil drill.

  26. Post #66
    SB2DevTeam's Avatar
    September 2007
    384 Posts
    PuddlePirate posted:
    Correct, But if you know some lua you can whip up a ent that creates the juice, something like to the oil drill.
    Or you could make an addon and create a new terraformer that uses different resources (It's been made so other other devs can easily add new TerraFormers, Air and Heat Exchangers without needing to put them over the new ones (it just depends on the registration and some vars).

    I've already put some info about it in the FAQ's of the official website.

  27. Post #67
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Looking through your code made me recognizing this:
    base_rd_entity/init.lua
    function ENT:OnTakeDamage(DmgInfo)//should make the damage go to the shield if the shield is installed(CDS)
    	if ent.Shield then
    		ent.Shield:ShieldDamage(DmgInfo:GetDamage())
    		CDS_ShieldImpact(self.Entity:GetPos())
    		return
    	end
    	DamageLS(self, DmgInfo:GetDamage())
    end
    Neither ent nor ent.Shield is defined in there and may produce lua errors (tried to index a nil value)

  28. Post #68
    Gold Member
    Catdaemon's Avatar
    February 2005
    2,821 Posts
    aVoN posted:
    Looking through your code made me recognizing this:
    base_rd_entity/init.lua
    function ENT:OnTakeDamage(DmgInfo)//should make the damage go to the shield if the shield is installed(CDS)
    	if ent.Shield then
    		ent.Shield:ShieldDamage(DmgInfo:GetDamage())
    		CDS_ShieldImpact(self.Entity:GetPos())
    		return
    	end
    	DamageLS(self, DmgInfo:GetDamage())
    end
    Neither ent nor ent.Shield is defined in there and may produce lua errors (tried to index a nil value)
    Why would that produce errors?

  29. Post #69
    Gold Member
    Xera's Avatar
    November 2006
    3,097 Posts
    Catdaemon posted:
    Why would that produce errors?
    Because it does.

    If it was
    if ent and ent.Shield then
    

    It wouldn't.

    But still, ent isn't being defined.

  30. Post #70
    Gold Member
    aVoN's Avatar
    December 2005
    2,880 Posts
    Yes, it actually even does :)
    Code:
    Error: [Scripted Entity Function] entities/base_rd_entity/init.lua:34: attempt to index global 'ent' (a nil value)

  31. Post #71
    SB2DevTeam's Avatar
    September 2007
    384 Posts
    aVoN posted:
    Yes, it actually even does :)
    Code:
    Error: [Scripted Entity Function] entities/base_rd_entity/init.lua:34: attempt to index global 'ent' (a nil value)
    Is already fixed in the svn (since yesterday). Tad just needs to upload it.

  32. Post #72

    September 2007
    1 Posts
    Hi, is there a bug with the cutoff valve?I see you have "No cutoff valve hax" but i am not sure if this means it's not supposed to work, or if it's a bug.

    I have not used version 1 before so i am not sure about the history of this, but the current one seems cool!

  33. Post #73
    Q42
    Q42's Avatar
    August 2006
    160 Posts
    I'm working on a different approach to RD. I found the old one poorly thought out and buggy as shit, so I started making one from scratch. The problem is that the resources in RD have always been abstract values with very little importance to the player, since EVERY resource acts like electricity.

    I'm doing it by making the dev define a "header" type dealie so that other parts of the script have a fairly low-cost reference point for dynamic factors, like rate of flow, density, that kind of thing. If you go to www.gamedev.net, there are no shortage of fluid dispersing algorithms, and they take so little to run that there's really no point in having resources propagate instantly.

  34. Post #74
    Gold Member
    subenji99's Avatar
    May 2005
    3,568 Posts
    I've found a bug in RD2 while experimenting with it.

    The new Link Junctions Don't update to each other properly if you have a chain of them. I'll try to explain:

    Say you have

    Solar Panel > Junction > Energy Cache

    and then add

    Junction > new 2nd Junction

    then add to that

    2nd Junction > Coolant Compressor
    2nd Junction > Large Coolant Tank

    The Coolant resources do not get updated on the first Junction unless the 2 junctions are reconnected after there is coolant listed on the 2nd junction list.

    With a large network of junctions, this lack of distribution can get awkward when resources at one end are needed at the other - the links through the whole network need to be rebuilt.

    Hope I made sense :P

  35. Post #75
    Gold Member
    tad2020's Avatar
    December 2006
    163 Posts
    subenji99 posted:
    I've found a bug in RD2 while experimenting with it.

    The new Link Junctions Don't update to each other properly if you have a chain of them. I'll try to explain:

    Say you have

    Solar Panel > Junction > Energy Cache

    and then add

    Junction > new 2nd Junction

    then add to that

    2nd Junction > Coolant Compressor
    2nd Junction > Large Coolant Tank

    The Coolant resources do not get updated on the first Junction unless the 2 junctions are reconnected after there is coolant listed on the 2nd junction list.

    With a large network of junctions, this lack of distribution can get awkward when resources at one end are needed at the other - the links through the whole network need to be rebuilt.

    Hope I made sense :P
    Damn it, someone must have broken it while I was away, that was all working last time I was working on it.

  36. Post #76
    Audio Enthusiast
    Tezzanator92's Avatar
    June 2006
    2,793 Posts
    I had the same issue with the junctions during development. I told space and snake about it and apparently they knew about the issue :)

  37. Post #77
    Gold Member
    tad2020's Avatar
    December 2006
    163 Posts
    Q42 posted:
    I'm working on a different approach to RD. I found the old one poorly thought out and buggy as shit, so I started making one from scratch. The problem is that the resources in RD have always been abstract values with very little importance to the player, since EVERY resource acts like electricity.
    It's more like sub-ether.

    Q42 posted:
    I'm doing it by making the dev define a "header" type dealie so that other parts of the script have a fairly low-cost reference point for dynamic factors, like rate of flow, density, that kind of thing. If you go to www.gamedev.net, there are no shortage of fluid dispersing algorithms, and they take so little to run that there's really no point in having resources propagate instantly.
    My appeoach was a rather simple idea: A network is just a table shared between linked ents and you don't have to rebuild a net to add to it.
    The old RD used propagation to update nets, each ent had a net tab that recursed to all linked ents, this was rather slow. RD2 only has to change the values in one tab and the update it done. I was only replicating the functions of RD1 for right now, RD3 will add new functions to make custom nets that can work however you want (it's just a table that's shared between link ents, you can do all sorts of stuff with that). I was going to add a net type that would work like a CPU (or more like a real power supply via amps).

  38. Post #78
    kevkev's Avatar
    April 2007
    1,093 Posts
    I have a small question,
    When is the debugging text being removed bycose my server console is being spammed with Pumping Air and that kind of stuff and its getting verry anoying.

  39. Post #79

    August 2007
    512 Posts
    Links don't seem to work, Entities still disappearing. I did delete the other addons so... Well, nothing in the console, except for sv_cheats turning on and off. Anyone else seen this?


    I also touched my storage device with the physgun and it said:
    autorun/server/sv_resource2.lua:496: attempt to perform arithmetic on a nil value

  40. Post #80
    nagachief's Avatar
    June 2007
    403 Posts
    Midtown123 posted:
    Links don't seem to work, Entities still disappearing. I did delete the other addons so... Well, nothing in the console, except for sv_cheats turning on and off. Anyone else seen this?


    I also touched my storage device with the physgun and it said:
    autorun/server/sv_resource2.lua:496: attempt to perform arithmetic on a nil value
    Where is the Life Support Stuff located and where is the RD located? Also try and see if anything is conflicting. Use SVN if your not already. IF all else fails, reinstall Gmod.