1. Post #1
    Doom's Avatar
    August 2011
    591 Posts
    So yeah, I have this really weird lag issue with Hammer Editor. I'd like to start out by saying this has NOTHING to do with my specs, I'm sure.

    Why am I sure? Well, changing the rendering distance of the camera window changes nothing, also deselecting all vision groups but a small one does not affect anything either, so it's not the rendering which is an issue. Also, this is something that randomly happens, sometimes it's fine, sometime's it's okay and other times, like now, it's awful. I'm currently running on a frame a second... Literally

    What happens is this; when I fly around in the camera window I usually lag, and when I use my grid it also lags. However, if I just change the camera angle, without moving, everything works great, no lag what so ever.

    I've been reading a bit on other forums, and I think it's a compatibility issue with Windows 7, so I wonder if anyone know how to run Hammer in compatibility mode for XP?

    Thanks :)

    EDIT: I know people are going to ask for my specs regardless so here they are:


    Operating System
    MS Windows 7 Home Premium 64-bit
    CPU
    AMD Phenom II X4 965
    Deneb 45nm Technology
    RAM
    6,00 GB Dual-Channel DDR3 @ 669MHz (9-9-9-24)
    Motherboard
    Gigabyte Technology Co., Ltd. GA-MA78LMT-US2H (Socket M2)
    Graphics
    P205H (1600x900@59Hz)
    1024MB GeForce GTX 460 (Gigabyte)

  2. Post #2
    paulisdead18's Avatar
    March 2010
    1,004 Posts
    Few possibilities. First, lots of things on the grid and map, which can be solved by using the Cordon tools. Second, could be specs, but you said you were sure they weren't. Third, you could have "Radius Culling" turned on. I've accidentally turned it on once and it lagged my hammer bad, and caused a leak. The button to turn it off is the button w/ the red circle and the "R" inside of it. Make sure that's off.
    Reply With Quote Edit / Delete Reply Windows Vista United States Show Events Winner Winner x 2Useful Useful x 1Mapping King Mapping King x 1Informative Informative x 1 (list)

  3. Post #3
    Doom's Avatar
    August 2011
    591 Posts
    Few possibilities. First, lots of things on the grid and map, which can be solved by using the Cordon tools. Second, could be specs, but you said you were sure they weren't. Third, you could have "Radius Culling" turned on. I've accidentally turned it on once and it lagged my hammer bad, and caused a leak. The button to turn it off is the button w/ the red circle and the "R" inside of it. Make sure that's off.
    Why, that was a quick fix. I expected to sit here for a couple of hours stressing over this issue... Thanks a lot, bro xD