1. Post #1

    July 2011
    19 Posts
    Well,This has started when I began playing Multiplayer on Gmod,Crashes have started,And when there's a crash,I can't access the server anymore...The game crashes when I'm attempting to join again...
    This also happens in other servers that I have never been in...
    So anyone can tell me what the heck is wrong with Garrysmod?
    Here's a Log:
    http://pastebin.com/WjzypHax

    P.S.
    I am using a Mac,Specs are:
    Mac OSX 10.5.8
    ATi Radeon 2650 HD Pro
    2 GB Ram
    2.7 Ghz

    Thanks!

    EDIT:
    It appears to be that I have missed the Subforum of the Actual Of Help & Support,Sorry about that one,Won't happen again...
    Reply With Quote Edit / Delete Mac Israel Show Events

  2. Post #2
    jdcoolha's Avatar
    June 2010
    22 Posts
    I tend to have this problem too, also running a Mac.
    Mac OSX 10.6.6
    Nividia GeForce 9400m
    4 GB Ram
    2.4 GHz

    It sometimes helps if I go to Steam, Library, right-click gmod, local files, do a scan and defragment of the game files, and then leave my computer off for a couple of minutes.
    Reply With Quote Edit / Delete Mac United States Show Events

  3. Post #3
    The Unforgotten's Avatar
    April 2010
    646 Posts
    Try starting a single player server before hand
    Reply With Quote Edit / Delete Windows 7 Ireland Show Events

  4. Post #4

    July 2011
    19 Posts
    Try starting a single player server before hand
    Tried to,Did not work,And thanks for atleast replying and helping...Unlike in Steam forums...

    And
    I tend to have this problem too, also running a Mac.
    Mac OSX 10.6.6
    Nividia GeForce 9400m
    4 GB Ram
    2.4 GHz

    It sometimes helps if I go to Steam, Library, right-click gmod, local files, do a scan and defragment of the game files, and then leave my computer off for a couple of minutes.
    Tried to...
    I have tried the following next things:
    -Deleting all my Addons - Didn't help
    -Cleaned the Cache folder completely - Didn't help
    -Unchecked the box of Team Fortress 2 and Day of Defeat : Source in the extensions - Didn't help
    Reply With Quote Edit / Delete Mac Israel Show Events

  5. Post #5
    101% Asian
    Banhfunbags's Avatar
    April 2007
    2,063 Posts
    I'm having this problem also. I'm glad to see I'm not the only person that's getting this.
    Reply With Quote Edit / Delete Windows 7 United States Show Events Agree Agree x 15 (list)

  6. Post #6

    July 2011
    19 Posts
    Then it appears to be that its not Mac only,This also applies on Windows...
    Maybe try to post a log,And someone would hopefully take a close look at it...?
    Reply With Quote Edit / Delete Mac Israel Show Events

  7. Post #7
    101% Asian
    Banhfunbags's Avatar
    April 2007
    2,063 Posts
    Edit: Derp
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  8. Post #8
    Gold Member
    DatMeg's Avatar
    March 2010
    2,055 Posts
    Try to find a dump file for hl2.exe in the dumps folder (generally Steam/dumps/) and upload it to

    http://www.dumps.garrysmod.com
    Reply With Quote Edit / Delete Windows 7 United States Show Events Dumb Dumb x 1 (list)

  9. Post #9
    Gold Member
    Zupinata's Avatar
    May 2006
    923 Posts
    I think I have the same error, Im trying to start a multiplayer server, and gmod just crashes with either "Lua dump error", or "Steam.dll isnt worthy of our trust"
    Reply With Quote Edit / Delete Windows Vista United States Show Events

  10. Post #10

    July 2011
    19 Posts
    Try to find a dump file for hl2.exe in the dumps folder (generally Steam/dumps/) and upload it to

    http://www.dumps.garrysmod.com
    DatMeg,Thank you for replying,But I can't find that dumps folder you are talking about,And also,The link you gave me isn't working from somereason...
    Also,I found out what causes me to crash,Those objects that are added to Garry's Mod,I spawned a Wheel pack prop or something,Game froze and crashed,Then at the specific Server I did that,I couldn't join anymore...
    Reply With Quote Edit / Delete Mac Israel Show Events Disagree Disagree x 1 (list)

  11. Post #11
    {Deadb4t}'s Avatar
    April 2011
    85 Posts
    This is just a random guess and I may be completely wrong here but a friend of mine had a problem with killing floor,and we came to the conclusion it was because he didn't update his video card drivers... Anyway sorry I cant be of much more help than that, good luck!
    Reply With Quote Edit / Delete Windows 7 Netherlands Show Events

  12. Post #12

    July 2011
    19 Posts
    This is just a random guess and I may be completely wrong here but a friend of mine had a problem with killing floor,and we came to the conclusion it was because he didn't update his video card drivers... Anyway sorry I cant be of much more help than that, good luck!
    My Mac drive is up-to-date,Since my Mac informs me everytime when there's an available update,An Software update application pops up and asks me if I am interested updating anything that has an update to apply...
    Well thanks,Any comment is somehow helpful... :)

    I think I have the same error, Im trying to start a multiplayer server, and gmod just crashes with either "Lua dump error", or "Steam.dll isnt worthy of our trust"
    I am not getting any erros,the game just crashes instantly when trying to join a server,And this crash happens in the "Retrieving Server info" thing stage...
    Reply With Quote Edit / Delete Mac Israel Show Events Agree Agree x 2Disagree Disagree x 1 (list)

  13. Post #13

    July 2011
    19 Posts
    Sorry for bumping,But this is getting annoying!!!
    Almost all the servers that I have played,I crashed in them,And now I can't play them anymore.
    Reply With Quote Edit / Delete Mac Israel Show Events

  14. Post #14
    Star Extraordinaire
    Blazyd's Avatar
    May 2011
    4,484 Posts
    Same, I played last night and it was fine. Today it just crashes when it reaches "Sending Client Info"
    Reply With Quote Edit / Delete Windows 7 United States Show Events Agree Agree x 10 (list)

  15. Post #15

    July 2011
    19 Posts
    Try to find a dump file for hl2.exe in the dumps folder (generally Steam/dumps/) and upload it to

    http://www.dumps.garrysmod.com
    DatMeg,I think your the one who can help me,But the problem is,I am not the only Mac user who can't find that Dump file!
    Reply With Quote Edit / Delete Mac Israel Show Events

  16. Post #16
    LtKyle2's Avatar
    March 2011
    4,300 Posts
    I also get this except it's when I'm trying to join singleplayer, it crashes when it reaches "Initializing Resources". It also happens when I load another gamemode such as sandbox. hl2.exe would run fine until recently.
    Reply With Quote Edit / Delete Windows 7 United States Show Events Agree Agree x 1 (list)

  17. Post #17

    September 2005
    9 Posts
    i'm having the same problem and is getting worse.. now i can't even get in-game before i crash. as everyone else here has stated before, i have reinstalled my garry's mod and tried joining a server with NO addons. still crashes when it reaches "sending client info". my drivers are up to date also.. here is my dump log http://dumps.garrysmod.com/?view=3826082680&refresh=16
    Reply With Quote Edit / Delete Windows 7 United States Show Events Agree Agree x 1 (list)

  18. Post #18
    nerohero's Avatar
    July 2011
    86 Posts
    This is terrible. Same thing happens to me all the time. I would wait for like 2-15 minutes for the downloads, then it reaches "Sending client info" and there's one bar left on the loading line then it crashes. I get "hl2.exe stopped working". This is total B.S.

    Btw, I have Windows

    EDIT: I uninstalled Garry's Mod and now I'm reinstalling it. Will tell how it goes later.
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  19. Post #19
    Gold Member
    DatMeg's Avatar
    March 2010
    2,055 Posts
    Lets try a clean install of Garry's Mod (this is not using "DELETE LOCAL CONTENT")
    1. Go to the Garry's Mod directory (steam/steamapps/<steamname>/garrysmod/)
    2. Rename the garrysmod folder to garrysmodold or whatever tickles your fancy
    3. Start up Garry's Mod.

    If that resolves your problem it was one of the addons/scripts that were causing the crash.
    If not then it could be your system or something else.
    Reply With Quote Edit / Delete Windows 7 United States Show Events Disagree Disagree x 3Useful Useful x 2Dumb Dumb x 1Agree Agree x 1 (list)

  20. Post #20
    tpops123's Avatar
    April 2011
    92 Posts
    Same, been doing this since January before I had any addons or anything for the game, I have a Mac too.
    Reply With Quote Edit / Delete Mac United States Show Events

  21. Post #21
    nerohero's Avatar
    July 2011
    86 Posts
    I followed what DatMeg said and I think it worked. I was also having an issue with pink and black checkers although I own almost every Garry's Mod compatible game and it fixed that.
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  22. Post #22

    September 2005
    9 Posts
    Lets try a clean install of Garry's Mod (this is not using "DELETE LOCAL CONTENT")
    1. Go to the Garry's Mod directory (steam/steamapps/<steamname>/garrysmod/)
    2. Rename the garrysmod folder to garrysmodold or whatever tickles your fancy
    3. Start up Garry's Mod.

    If that resolves your problem it was one of the addons/scripts that were causing the crash.
    If not then it could be your system or something else.
    Yes, when I reinstalled Garry's Mod, I manually deleted the folder and then reinstalled. I don't crash during connection anymore, but I still crash 5 to 10 minutes after I join a server.

    I also noticed deleting the cache files in garrysmod/cache/dua folder helps alleviate the problem some, but I still accumulate like 900+ files in there.

    BTW: I'm on windows 7

    My last two dump analysis: Says i crashed on tier0.dll and shaderapidx9.dll

    http://dumps.garrysmod.com/?view=19862380&refresh=14
    http://dumps.garrysmod.com/?view=3720030070&refresh=15
    Reply With Quote Edit / Delete Windows 7 United States Show Events Friendly Friendly x 1 (list)

  23. Post #23

    July 2011
    4 Posts
    I think it has something to do with the recent update, i wasnt crashing before that. I'm also on a mac.
    Reply With Quote Edit / Delete Mac United States Show Events

  24. Post #24

    July 2011
    19 Posts
    Lets try a clean install of Garry's Mod (this is not using "DELETE LOCAL CONTENT")
    1. Go to the Garry's Mod directory (steam/steamapps/<steamname>/garrysmod/)
    2. Rename the garrysmod folder to garrysmodold or whatever tickles your fancy
    3. Start up Garry's Mod.

    If that resolves your problem it was one of the addons/scripts that were causing the crash.
    If not then it could be your system or something else.
    DatMeg,Thanks for your reply,But I am still having the Crashing issue.
    I found out that if the Server's Content is being changed,I can enter that server again,It appears to be that it has something to do with the Cache files...
    Reply With Quote Edit / Delete Mac Israel Show Events

  25. Post #25
    Gold Member
    MisterSpuds's Avatar
    October 2006
    370 Posts
    I've also been starting to crash recently. It started off on just one server, but now it seems every server I go to it crashes.
    Reply With Quote Edit / Delete Windows Vista United Kingdom Show Events

  26. Post #26
    A spaicrab :D's Avatar
    January 2011
    63 Posts
    Lets try a clean install of Garry's Mod (this is not using "DELETE LOCAL CONTENT")
    1. Go to the Garry's Mod directory (steam/steamapps/<steamname>/garrysmod/)
    2. Rename the garrysmod folder to garrysmodold or whatever tickles your fancy
    3. Start up Garry's Mod.

    If that resolves your problem it was one of the addons/scripts that were causing the crash.
    If not then it could be your system or something else.
    It just says that the folder is open somewhere else and it wont let me.
    Reply With Quote Edit / Delete Windows 7 Canada Show Events

  27. Post #27
    LTDEAD's Avatar
    September 2011
    15 Posts
    Alright now I know someone already suggested starting in single player, but did you start the map the server was running? And if so did you at least run around the map for a minute or two? It may be that the engine gets overloaded when loading large maps.
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  28. Post #28
    cookingboy3's Avatar
    July 2010
    39 Posts
    It just says that the folder is open somewhere else and it wont let me.
    Make sure HL2.exe is closed before trying to do this.

    Edited:

    (bump) I'm getting this too, gets to Sending Client Info, then goes and stops responding, I fed the machine my dump. http://dumps.garrysmod.com/?view=1744983610
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  29. Post #29
    ─ ─ ─ ─ ─▀ ▀ ▀ ▌ ─ ─ ─ ▄ ▄ █ █ ▌ █ ░ ♥ ░ HONK HONK- ITS A TRUCK ░░ ♥ ░░ ░ ░ ▐ ▄ ▄ ▄ ▌ ▐ █ █ ▌ █ ░ ♥ ░ FULL OF DICKS ░░░ ░ ♥
    Jarrod's Avatar
    December 2010
    1,082 Posts
    Try to find a dump file for hl2.exe in the dumps folder (generally Steam/dumps/) and upload it to

    http://www.dumps.garrysmod.com
    Macs DON'T create dumps...for fuck sake, stop copy-paste replying and READ.

    Edited:

    Other then that... I don't see why you guys with windows 7 are having that problem. The only time I crash is when my graphics card shits out or meet any other reasons that perfectly happen with reason (I.E. spawning too many props).
    Reply With Quote Edit / Delete Windows 7 United States Show Events Dumb Dumb x 1 (list)

  30. Post #30

    January 2012
    1 Posts
    I've had this problem for about 6 months now... really annoying. I've tried everything to fix it: Cache deletion, local game file deletion and EVERYTHING ELSE. Most the wire servers are fine to join, but not the regulars. Not sure why though.
    Reply With Quote Edit / Delete Mac Sweden Show Events

  31. Post #31
    walty005's Avatar
    February 2012
    26 Posts
    Yeah, same is happening for me. I tried re-installing and nothing, I could connect fine before I changed my graphics card.
    Reply With Quote Edit / Delete Windows 7 United Kingdom Show Events

  32. Post #32
    Update your graphic card drivers.
    Reply With Quote Edit / Delete Windows 7 Germany Show Events Dumb Dumb x 9Funny Funny x 3Disagree Disagree x 1 (list)

  33. Post #33
    kibbols's Avatar
    July 2011
    454 Posts
    i've had the same problem, i crashed every once in a while. then it became more frequent. now all of a sudden i can't even get in-game on the server before it crashes :(
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  34. Post #34
    Evil Boy Genius
    Rageguy's Avatar
    May 2011
    3,926 Posts
    Im starting to get this too.
    Reply With Quote Edit / Delete Windows 7 United States Show Events

  35. Post #35
    Assault_Trooper's Avatar
    March 2010
    459 Posts
    Nice bumping. Anyway, launch single player, and then join a server. Stops the crashing.
    Reply With Quote Edit / Delete Windows 7 Finland Show Events

  36. Post #36
    TF2 Engie's Avatar
    May 2012
    11 Posts
    I'm sorry if this is late, but it Assault_Trooper's Solution doesn't work, your computer is overheating, try taking off the side, or even take of the side and put your fan on low power next to it.
    Reply With Quote Edit / Delete Windows Vista United Kingdom Show Events

  37. Post #37

    May 2012
    3 Posts
    I know this is a bump, but this is a serious problem. I think Gmod started crashing today after it updated, but I'm not sure. None of the fixes on this topic have worked. I'm running Windows 7, if anyone has a fix for this PLEASE post!
    Reply With Quote Edit / Delete Windows 7 United States Show Events Agree Agree x 5Dumb Dumb x 4 (list)

  38. Post #38
    Detective Hoop's Avatar
    November 2010
    65 Posts
    Gmod crashes on every server join. It was working for me earlier today and now its gone to crap.
    Reply With Quote Edit / Delete Windows 7 Afghanistan Show Events

  39. Post #39
    Gold Member

    February 2012
    46 Posts
    It's the new TF2, Source Engine, etc update that broke Gmod and there's nothing we can do 'till Garry fixes it.
    Reply With Quote Edit / Delete Windows Vista United Kingdom Show Events Useful Useful x 1 (list)

  40. Post #40
    Detective Hoop's Avatar
    November 2010
    65 Posts
    Garry fixed the link to download the beta on his website. Im gonna check it out and see if I can get in a game.
    Reply With Quote Edit / Delete Windows 7 Afghanistan Show Events