1. Post #1
    Posting in OIFY without a permit
    Its Waffles's Avatar
    January 2013
    360 Posts
    Hello, I recently have been working on a custom F4 menu... I also edited the DarkRPSkin.png in Photoshop.

    I have my edited png file in "gamemodes/darkrp/content/materials/darkrp"
    and I have edited my "gamemodes/darkrp/gamemode/client/DRPDermaSkin.lua" to look like this:
     SKIN.GwenTexture	 = Material("DarkRP/sp.png") 

    I also have the sp.png located in "materials/darkrp" along with te hresorceAddFile.

    The png just dose NOT download and shows up as checkers....

    I have no idea what the problem is.
    Reply With Quote Edit / Delete Reply Show Events Disagree Disagree x 1 (list)

  2. Post #2

    July 2013
    14 Posts
    Did you add the file to your FastDL? Also, you said you did the resource.AddFile; does it look something like this?
    Code:
    resource.AddFile("materials/darkrp/sp.png")

  3. Post #3
    Gold Member
    Mitsudigi's Avatar
    July 2005
    423 Posts
    Sometimes capitalized folders can cause issues with Fast DL. Make sure the DarkRP folder is the same case on both the HTTP and the game server.

  4. Post #4
    Posting in OIFY without a permit
    Its Waffles's Avatar
    January 2013
    360 Posts
    This what I have:

    I have sp.png in this path
     materials/darkrp/sp.png 

    My FastDL looks like this:
     resource.AddFile( "materials/darkrp/sp.png" ) 

    and my DRPDermaSkin.lua has this in it:
     SKIN.GwenTexture		= Material("darkrp/sp.png") 

    As you can see, there should be NO problem... But there is.

  5. Post #5
    Gold Member
    J.R.'s Avatar
    December 2009
    155 Posts
    https://github.com/FPtje/DarkRP/blob...onfig.lua#L240

    ^ that would be easy prolly idk just figured I would show you its there.

  6. Post #6
    Posting in OIFY without a permit
    Its Waffles's Avatar
    January 2013
    360 Posts
    https://github.com/FPtje/DarkRP/blob...onfig.lua#L240

    ^ that would be easy prolly idk just figured I would show you its there.
    I don't think that is the problem, because it worked fine in single player...
    It just dose not want to FastDL.

  7. Post #7
    Gold Member
    Koolaidmini's Avatar
    May 2013
    225 Posts
    Make sure you have your server.cfg set up with fastDL properly. ie;

    sv_downloadurl
    sv_allowdownload
    sv_allowupload

    Also, you must change the skin in your config, inside your darkRP gamemode.

  8. Post #8
    Posting in OIFY without a permit
    Its Waffles's Avatar
    January 2013
    360 Posts
    Make sure you have your server.cfg set up with fastDL properly. ie;

    sv_downloadurl
    sv_allowdownload
    sv_allowupload

    Also, you must change the skin in your config, inside your darkRP gamemode.
    This is set
    sv_downloadurl
    sv_allowdownload
    sv_allowupload

    My FastDL works and Downloads all other files, just not the sp.png.

    Also ,what do you mean by change your skin in the config?
    Because as I said before, it works fine in single player.

  9. Post #9
    Gold Member
    Koolaidmini's Avatar
    May 2013
    225 Posts
    "DarkRP/gamemode/config.lua"

    Line 240:
    Code:
    GM.Config.DarkRPSkin = "DarkRP"

  10. Post #10
    Gold Member
    Ludicium's Avatar
    March 2012
    173 Posts
    I thought Garry still hasn't implemented being able to change the default gwen textures?

  11. Post #11
    Gold Member
    Koolaidmini's Avatar
    May 2013
    225 Posts
    Just try it;;