1. Post #2161
    imacc2009's Avatar
    September 2013
    435 Posts
    More questions, sorry if this is pretty much "spamming" at this point but hey, you gotta have info to have a good server. Anyway, how do I add ration dispensers and vending machines? I know about the /vendoradd command, but that isn't it, and I don't see ANY commands like /rationadd or /vendingmachineadd. Wat?
    You can find them on the entitys list or use help in the F1 menu.

  2. Post #2162
    Nope guy's Avatar
    January 2012
    73 Posts
    More questions, sorry if this is pretty much "spamming" at this point but hey, you gotta have info to have a good server. Anyway, how do I add ration dispensers and vending machines? I know about the /vendoradd command, but that isn't it, and I don't see ANY commands like /rationadd or /vendingmachineadd. Wat?
    Or you can just access the spawn menu > Entities and spawn the vending machine and ration dispensers yourself and place them correctly.

  3. Post #2163
    RonanZer0's Avatar
    January 2012
    321 Posts
    OH MAN, THIS IS BAD...
    So I was just playing RP normally, I turned off the server with the "exit" command on srcds. Then I went to sleep, woke up, turned the server on, joined it and this was the start of the weird things.

    First of all, my characters are kept and fine, but now it says I'm in the 'user' group of the server. Note that I made NO changes whatsoever to the server between restarting it, just waiting some hours. OK, but wait, there's more. ALL of my doors that I spent hours using /doorsetunownable on are now OWNABLE!?!? Ugh... and all of my 3rd person plugin settings where reset, it probably has to do with this though seeing as a lot of things are glitching out. I did however do ONE thing before I restarted it. All I did was change the max characters from 4, to 6. NOTHING else. What the crap happened!? I AM getting one error, though, it's this, out of nowhere:

    Code:
    [ERROR] gamemodes/nutscript/gamemode/libs/external/sh_von.lua:131: vON: Malformed data... Can't find a proper type definition. Char#1:
    1. error - [C]:-1
    2. d_findVariable - gamemodes/nutscript/gamemode/libs/external/sh_von.lua:131
    
    3. deserialize - gamemodes/nutscript/gamemode/libs/external/sh_von.lua:198
    4. ReadTable - gamemodes/nutscript/gamemode/sh_util.lua:271
    5. unknown - gamemodes/nutscript/plugins/3dtext.lua:35
    6. Run - gamemodes/nutscript/gamemode/libs/sh_schema.lua:110
    7. unknown - gamemodes/nutscript/gamemode/core/sv_hooks.lua:313
    And just when my server was starting to get more players :(


    EDIT: Another bad problem with this, ever since this happened, everybody has to reconnect to switch characters, or else they have the delete-character style glitch except while trying to click the choose button. -_- NEED HELP!!!

  4. Post #2164
    ReapDaWrapper's Avatar
    October 2009
    592 Posts
    Anyone know where I can find a list of animgroups?









    also:
    I thought this looked kinda silly haha.


  5. Post #2165
    RonanZer0's Avatar
    January 2012
    321 Posts
    Anyone know where I can find a list of animgroups?









    also:
    I thought this looked kinda silly haha.

    How did you get the Slave Vort?

  6. Post #2166
    ReapDaWrapper's Avatar
    October 2009
    592 Posts
    Search for it in your Q menu. It's pretty easy to find.

  7. Post #2167
    Sanic Hegehog's Avatar
    June 2013
    6 Posts
    Okay, I'm kinda stumped over some stupid little thing that has been driving me nuts. I've been able to make grub's RO2 mosin (http://steamcommunity.com/sharedfile.../?id=145730038) into a schema item for my WW1RP server, but here's the thing. I just can't seem to figure out how to make it's ammo into one. The weapon uses a custom base, so someone who's new to LUA scripting like me can't really figure out what to do to get it to work. Here's what I've tried:
    Code:
    ITEM.name = "Mosin Ammo"
    ITEM.weight = 0.5
    ITEM.price = 5
    ITEM.desc = "A cartridge of bullets used in mosin bolt action rifles."
    ITEM.type = "7.62x54mmR"
    ITEM.amount = 5
    ITEM.flag = "v"
    ITEM.model = Model("models/weapons/ammo/grub_stripper.mdl")
    Someone wanna tell an insufferable asshat what he's doing wrong?

  8. Post #2168
    RubixGamer's Avatar
    October 2012
    15 Posts
    HAS ANYONE been able to get clothing items to set bodygroups!? If you have can you show me an example, I can't work this out!?

  9. Post #2169
    RonanZer0's Avatar
    January 2012
    321 Posts
    How do you set stamina and Max HP? And maybe walk/run speeds and separate Hp/Stamina/whatever stats for each faction/class? Like I want rebels to maybe have +100 armor while wearing their clothes, and Combine soldiers should always have +100 armor, CPs +80 etc. and you should be able to maybe also run faster with rebel clothes on and such. So how do I do it?

  10. Post #2170
    ReapDaWrapper's Avatar
    October 2009
    592 Posts
    How do you set stamina and Max HP? And maybe walk/run speeds and separate Hp/Stamina/whatever stats for each faction/class? Like I want rebels to maybe have +100 armor while wearing their clothes, and Combine soldiers should always have +100 armor, CPs +80 etc. and you should be able to maybe also run faster with rebel clothes on and such. So how do I do it?

    For your learning sake, go look through some scripts and look for 'if then' functions or statements. With those in mind, find the file with stamina/health/armor settings, and note those as well. Now go to the item scripts relevant, and use trial and error to figure out how to set that up within the item code. No one on the forum is going to continuously baby feed you on how to write or modify your script, so try to interpret information for yourself so you don't have to ask all the time.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Agree Agree x 1 (list)

  11. Post #2171
    BEST HL2RP SCHEMA
    Reyjr43's Avatar
    November 2010
    255 Posts
    Okay, I'm kinda stumped over some stupid little thing that has been driving me nuts. I've been able to make grub's RO2 mosin (http://steamcommunity.com/sharedfile.../?id=145730038) into a schema item for my WW1RP server, but here's the thing. I just can't seem to figure out how to make it's ammo into one. The weapon uses a custom base, so someone who's new to LUA scripting like me can't really figure out what to do to get it to work. Here's what I've tried:
    Code:
    ITEM.name = "Mosin Ammo"
    ITEM.weight = 0.5
    ITEM.price = 5
    ITEM.desc = "A cartridge of bullets used in mosin bolt action rifles."
    ITEM.type = "7.62x54mmR"
    ITEM.amount = 5
    ITEM.flag = "v"
    ITEM.model = Model("models/weapons/ammo/grub_stripper.mdl")
    Someone wanna tell an insufferable asshat what he's doing wrong?
    Some weapons use custom entities for things like that, instead of trying to create the specific ammo-type you could try creating the entity.
    Reply With Quote Edit / Delete Reply United States Show Events Agree Agree x 1 (list)

  12. Post #2172
    RonanZer0's Avatar
    January 2012
    321 Posts
    Why does this not work?

    	onRun = function(player, client, arguments)
    

                    if ( client:IsCombine() ) then
    

    Attempt to call method ''IsCombine" (a nil value)

    Should I try it with player:IsCombine(), should I remove the player and replace it with client (may not work though) etc etc.?

    And, player:whatevergoeshere is used in other parts of the command.

  13. Post #2173

    August 2011
    20 Posts
    Hey there everyone, perhaps I could get a hand here. I've been looking around and seeing what I could do, but literally nothing has been working. I installed NutScript onto my server and I'm getting some errors.

    Here's the first bit.

    Code:
    TEST [lua/vgui/dnumslider_legacy.lua][lua/vgui/dlabel.lua]
    
    [ERROR] gamemodes/nutscript/gamemode/libs/external/sh_von.lua:150: attempt to call a nil value
      1. s_anyVariable - gamemodes/nutscript/gamemode/libs/external/sh_von.lua:150
       2. unknown - gamemodes/nutscript/gamemode/libs/external/sh_von.lua:447
        3. s_anyVariable - gamemodes/nutscript/gamemode/libs/external/sh_von.lua:150
         4. serialize - gamemodes/nutscript/gamemode/libs/external/sh_von.lua:429
          5. Start - gamemodes/nutscript/gamemode/libs/external/sh_netstream.lua:137
           6. DoClick - gamemodes/sstrp/gamemode/schema/derma/cl_charcreate.lua:304
            7. unknown - lua/vgui/dlabel.lua:206
    
    TEST [lua/vgui/dnumslider_legacy.lua][lua/vgui/dlabel.lua]

    No idea what any of this means so don't even ask. Though is I think there's an issue with the SQL or whatever. I know, I know. Leave it alone or whatever, but I've done fresh reinstalls of it, and still get the "Character creation request timed out!" or whatever. I've also had this popping up into the console.

    Code:
    [ERROR] gamemodes/nutscript/plugins/autocomplete.lua:14: attempt to call method 'IsTyping' (a nil value)
      1. unknown - gamemodes/nutscript/plugins/autocomplete.lua:14
       2. unknown - gamemodes/nutscript/gamemode/libs/sh_schema.lua:110
    I'm out of options and have literally no idea what I can do to fix this. Any advice?

  14. Post #2174
    RonanZer0's Avatar
    January 2012
    321 Posts
    What schema are you using? Are you using SQLite or MySQL?

  15. Post #2175

    August 2011
    20 Posts
    What schema are you using? Are you using SQLite or MySQL?
    Schema, it's a custom gamemode that a friend made.. That'd be correct, yeah?

    And I assume it's SQLite, since you only have to setup something if you're doing mysqloo or tmysql4, or at least that's what the tutorial said. (The tutorial that links to a broken wiki. :X )

  16. Post #2176
    Gold Member
    Ultimate7MK's Avatar
    April 2009
    3,061 Posts
    So I've been experiencing this... strange error. Just as a heads up I'm using the HL2RP schema. Anyways continuing on, whenever anyone including myself reloads any kind of gun whether it be the MP7, pistol, etc. the entire gun stops working. Meaning I can still raise it, but it will refuse to fire unless the whole gun is dropped and deleted from the face of the earth. There aren't any errors that show up in console. How can I fix this or is it even able to be fixed? Will I have to remake the sweps?

  17. Post #2177
    RonanZer0's Avatar
    January 2012
    321 Posts
    So I've been experiencing this... strange error. Just as a heads up I'm using the HL2RP schema. Anyways continuing on, whenever anyone including myself reloads any kind of gun whether it be the MP7, pistol, etc. the entire gun stops working. Meaning I can still raise it, but it will refuse to fire unless the whole gun is dropped and deleted from the face of the earth. There aren't any errors that show up in console. How can I fix this or is it even able to be fixed? Will I have to remake the sweps?
    I have this sometimes as well, definitely not EVERY time I reload but at seemingly random times after reloading. SUPER ANNOYING.

  18. Post #2178
    Gold Member
    Ultimate7MK's Avatar
    April 2009
    3,061 Posts
    I have this sometimes as well, definitely not EVERY time I reload but at seemingly random times after reloading. SUPER ANNOYING.
    Well it's everytime I reload while the gun isn't aiming. But many others have experienced it breaking and they always have the animation of reloading.

  19. Post #2179
    "The superior man understands what is right; the inferior man understands what will sell"
    Chessnut's Avatar
    August 2011
    3,504 Posts
    The wiki won't be hosted on my site. Instead, I'm going to try to use the GitHub wiki system.

    https://github.com/Chessnut/NutScript/wiki/nut.chat

    For example.

  20. Post #2180
    RonanZer0's Avatar
    January 2012
    321 Posts
    PLUGIN.name = "Set Skin"
    PLUGIN.author = "Omega"
    PLUGIN.desc = "Sets your skin."
        
    nut.command.Register({
        superAdminOnly = true,
        allowDead = true,
        syntax = "<number skin>",
            onRun = function(client, arguments)
            local target = nut.command.FindPlayer(client, arguments[1])
    
            if (IsValid(target)) then
                    
    			client:SetSkin(arguments[1])
    				
    		end
        end
    }, "charsetskin")
    
    

    why

    why does it not work, i want to be a shotgunner but i don't want to use a custom model for it

    help

    (YES IM SUPERADMIN THANK YOU VERY MUCH)

  21. Post #2181
    imacc2009's Avatar
    September 2013
    435 Posts
    PLUGIN.name = "Set Skin"
    PLUGIN.author = "Omega"
    PLUGIN.desc = "Sets your skin."
        
    nut.command.Register({
        superAdminOnly = true,
        allowDead = true,
        syntax = "<number skin>",
            onRun = function(client, arguments)
            local target = nut.command.FindPlayer(client, arguments[1])
    
            if (IsValid(target)) then
                    
    			client:SetSkin(arguments[1])
    				
    		end
        end
    }, "charsetskin")
    
    

    why

    why does it not work, i want to be a shotgunner but i don't want to use a custom model for it

    help

    (YES IM SUPERADMIN THANK YOU VERY MUCH)
    If you want to make yourself a shotgunner, make an Overwatch character and include SGS in the name.

  22. Post #2182
    RonanZer0's Avatar
    January 2012
    321 Posts

    I'm not sure if this only on the HL2 schema or basicly the framework.
    Can Chessnut PLEASE comment on this? Like at all? I'm having a similar issue where about 50% of the time after loading up the server, or changing map, this happens not only when you delete a character, but when you try to load one your second time after already picking one, and you have to A reconnect or B reload the server's map (still may glitch out). And about 5% of the time it won't even let you select your FIRST character ._. CHESSNUT PLS

  23. Post #2183
    "The superior man understands what is right; the inferior man understands what will sell"
    Chessnut's Avatar
    August 2011
    3,504 Posts
    This sounds like an issue with the database. I'm working on NS1.1 which should not have any of these issues.
    Reply With Quote Edit / Delete Reply United States Show Events Lua King Lua King x 1 (list)

  24. Post #2184
    Strangerdanger's Avatar
    November 2010
    13 Posts
    Hey Chessnut was the plugin on github for pac3 removed? Can't seem to find it.

  25. Post #2185
    RonanZer0's Avatar
    January 2012
    321 Posts
    This sounds like an issue with the database. I'm working on NS1.1 which should not have any of these issues.
    Yes there is a lot of issues with the database, like sometimes out of nowhere when we just start getting players, we will have some stupid MALFORMED DATA error in vON.lua and we have to reset everything :(

    EDIT: Just got that vON.lua malformed data thing again, you can see it about 3-4 pages ago if you want to see the full error. This seemingly happens out of absolutely nowhere, just turning on the server one day and POOF all our hard work and RP characters and whitelists etc. are gone.

    Here's another thing about it, when "saving" a character with the error:




    HELP CHESSNUT HELP D:

  26. Post #2186
    ReapDaWrapper's Avatar
    October 2009
    592 Posts
    Hey Chessnut was the plugin on github for pac3 removed? Can't seem to find it.
    https://github.com/Chessnut/NSPlugin...c3_outifts.zip

    I guess these are just pre-made outfits for PAC. I guess the PAC addon should work with Nutscript without any extra plugins or coding?

  27. Post #2187
    "The superior man understands what is right; the inferior man understands what will sell"
    Chessnut's Avatar
    August 2011
    3,504 Posts
    Ronan, it looks like it's an issue with your database.

  28. Post #2188
    RonanZer0's Avatar
    January 2012
    321 Posts
    Ronan, it looks like it's an issue with your database.
    I'm using the default settings (SQLite)

    In other questions:
    How to set walk/run speed for specific factions?

  29. Post #2189
    "The superior man understands what is right; the inferior man understands what will sell"
    Chessnut's Avatar
    August 2011
    3,504 Posts
    You can use client:SetRunSpeed on the PlayerSpawn hook. Just check their teams to the faction and set the runspeed appropriately.