1. Post #1
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    I understand that there have been a few similarly named threads as of late, however I believe that the source of my problems might be unlike the others.

    Previously in G-Mod 12, I had been able to project dynamic shadows through the use of flashlight console commands, and in the G-Mod 13 Beta I had been able to cast dynamic shadows with lamps. When G-Mod 12 had updated to version 13, I was completely unable to cast dynamic shadows, though normal shadows were still present. I do not seem to have this problem in other Source games. I have repeatedly validated my game cache, reinstalled the entire game multiple times, and even tinkered around with some of the console commands, though still to no avail.

    My video card is a GTX 660, so I don't think any of my problems are due to hardware obsolescence. All my graphics settings are at maximum and I have frequently checked for updates for my video card.

    I've been having this problem for a long time now and I'd like to know if there's a way to fix it.

  2. Post #2
    -snip-
    code_gs's Avatar
    March 2013
    10,969 Posts
    Take a screenshot of your options, I think I know what it is.

  3. Post #3
    Somonez's Avatar
    January 2010
    96 Posts
    Yeah.. I think it's a DirectX issue. My garrys mod keep setting me back to DirectX 7. When I try to force it into 98, it will stay until I turn up shadow options to High. Probably a bug with Garrys Mod.

  4. Post #4
    -snip-
    code_gs's Avatar
    March 2013
    10,969 Posts
    It is, that's why I asked for a screenshot so I could see his DirectX setting. It's been reported in the past.

    Edited:

    Try putting this in your launch options.
    Code:
    -dxlevel 95
    Reply With Quote Edit / Delete Reply United States Show Events Useful Useful x 1 (list)

  5. Post #5
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    Take a screenshot of your options, I think I know what it is.

  6. Post #6
    -snip-
    code_gs's Avatar
    March 2013
    10,969 Posts
    Try doing what I said in my previous post.

  7. Post #7
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    Try doing what I said in my previous post.
    It didn't work, even when I made sure the shadow quality was set to high.

  8. Post #8
    CoderHire
    James0roll's Avatar
    August 2012
    428 Posts
    Shadows are calculated when a map is compiled, so you can't "add" shadows. Lamps and flashlights only project textures to make it look like there are shadows, with an entity called env_projectedtexture.
    Reply With Quote Edit / Delete Reply Windows Vista United States Show Events Informative Informative x 1 (list)

  9. Post #9
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    Shadows are calculated when a map is compiled, so you can't "add" shadows. Lamps and flashlights only project textures to make it look like there are shadows, with an entity called env_projectedtexture.
    So why don't my lamps and flashlights project textures then? Are they lacking the env_projectedtexture entity?

  10. Post #10
    CoderHire
    James0roll's Avatar
    August 2012
    428 Posts
    So why don't my lamps and flashlights project textures then? Are they lacking the env_projectedtexture entity?
    When you say they're not projecting any textures? Do they not have a kind of black shadow on them? It wouldn't make a shadow like the sun casting a shadow over a static prop.

  11. Post #11
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    When you say they're not projecting any textures? Do they not have a kind of black shadow on them? It wouldn't make a shadow like the sun casting a shadow over a static prop.
    The props themselves do have shadows on them, as well as shadows below them. What I seem to lack are those big black shadows that appear behind props and (pardon my technical illiteracy) project onto the map geometry via lamps.

    Unless my definition of dynamic shadows is erroneous, that's what I always thought they were. Here's a picture that I had taken:


  12. Post #12
    Gold Member
    MrWhite's Avatar
    March 2010
    3,609 Posts
    When in game, hold "C", and in the upper left hand corner, there's a tab called "Drawing". Open it and ensure that "Draw Shadows" is ticked.

    That would be the only thing I could think of.

  13. Post #13
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    Open it and ensure that "Draw Shadows" is ticked.
    It is, and always was, unfortunately.

  14. Post #14
    CoderHire
    James0roll's Avatar
    August 2012
    428 Posts
    If these are custom entities, it might not have shadows enabled. Entity:DrawShadow(true) will enable a shadow for the entity. This should be set client side, perhaps with the ENT:Initialize hook, which should work for client side as well.

  15. Post #15
    God's Pimp Hand's Avatar
    May 2010
    1,385 Posts
    If these are custom entities, it might not have shadows enabled. Entity:DrawShadow(true) will enable a shadow for the entity. This should be set client side, perhaps with the ENT:Initialize hook, which should work for client side as well.
    I don't know how to do this. I'm entirely unfamiliar with Lua and the Source engine.