1. Post #241
    samm5506's Avatar
    July 2008
    598 Posts
    Im sorry for bumping this, but is there a way to enable like a sandbox mode on this? as in you can still spawn props and things like in normal sandbox, yet you can still play on cinema maps with it all still working? Im sorry if i missed something obvious. if it is something that would require coding, can someone then at least point me in the right direction?
    Place this at the top of cinema/gamemode/shared.lua
    Code:
    DeriveGamemode("sandbox")
    I really enjoy using this mod, it's fantastically executed.

    One feature I'd like to see though is support for sockshare and putlocker, which commonly host full tv shows and movies that you can't find on fullmoviesonvimeo or etc.
    It'd probably be pretty difficult since these websites don't have an open API for getting video metadata. They're mostly just hosts for storing generic files. Your best bet is to just stream the video after downloading it.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Lua King Lua King x 1 (list)

  2. Post #242
    da space core's Avatar
    March 2012
    1,070 Posts
    Place this at the top of cinema/gamemode/shared.lua
    Code:
    DeriveGamemode("sandbox")
    thanks for the reply, i tried doing what you said, but it isnt working. im no lua genius, i put the code right at the very top of the shared.lua file using notepad++ and it isnt working. am i making a mistake?

  3. Post #243
    da space core's Avatar
    March 2012
    1,070 Posts
    Sorry for bumping, but i am still not able to get it to work. Not sure if there may be something that prevents the spawnlist from loading or im too stupid to figure out where exactly to put
    Code:
    DeriveGamemode("sandbox")
    in the shared.lua file. i tried the very top, some places and between, and perhaps multiple places. may anyone help?

  4. Post #244
    samm5506's Avatar
    July 2008
    598 Posts
    The issue is that the gamemode overrides the controls to open the spawn menu and such. You're going to have to figure out how to change that yourself.

  5. Post #245
    da space core's Avatar
    March 2012
    1,070 Posts
    The issue is that the gamemode overrides the controls to open the spawn menu and such. You're going to have to figure out how to change that yourself.
    alright, thanks. Now is when im thankful for google

  6. Post #246

    December 2013
    14 Posts
    I'm a having a bit of an issue. I got everything working perfectly, everyone can join the server, watch videos and screw around...Except me :(.

    When a video gets loaded it takes AGES for me to load it when everyone else just instantly watches it... and sometimes it doesn't load at all. I see the youtube loading thingy and i can see still images of the video at random times...is this because i'm hosting? or is there a solution to it?

    i've already tried disabling hardware acceleration if that's any help.

    thank you so much for this mode, i've never thought i could share videos like this.

  7. Post #247
    da space core's Avatar
    March 2012
    1,070 Posts
    I'm a having a bit of an issue. I got everything working perfectly, everyone can join the server, watch videos and screw around...Except me :(.

    When a video gets loaded it takes AGES for me to load it when everyone else just instantly watches it... and sometimes it doesn't load at all. I see the youtube loading thingy and i can see still images of the video at random times...is this because i'm hosting? or is there a solution to it?

    i've already tried disabling hardware acceleration if that's any help.

    thank you so much for this mode, i've never thought i could share videos like this.
    its your internet connection. you may be able to help it by unchecking the hd video box in the tab menu. but its likely that your internet cant handle a server and a youtube video at the same time

  8. Post #248

    December 2013
    14 Posts
    its your internet connection. you may be able to help it by unchecking the hd video box in the tab menu. but its likely that your internet cant handle a server and a youtube video at the same time
    I thought that too, but vimeo and twitch.tv work perfectly, i can even watch a livestream without any lag...i thinks it has something to do with flash but i just can't quite get it right.

    I reinstalled it, reinstalled all my browsers, and all adobe related programs but i still can't get a youtube video working on the server for me...it's really odd.

    Edit: i joined other servers and i'm having the same issue and it also happens on singleplayer. So now i'm sure it's a flash problem, i can't even load videos from youtube while i'm requesting them, has anyone else experienced this problem?

  9. Post #249

    January 2014
    2 Posts
    Hey i just wanna signal a bug that i found and if its not a bug then let me know. Im posting this cause i didnt see anyone with the problem so i posted it here where i could be answered. So the bug is that everytimes i select the video (Any, even livestream) it keep saying invalid request. Help!

  10. Post #250
    AlphaBarney's Avatar
    January 2014
    21 Posts
    I saw some people ask for a local chat system where players don't see local chat between theaters. Now I am not very experienced in lua yet, but I'm learning and I managed to make a system that works. This chat will make all theaters local chat be only within the theater itself and all the of lobby locations are connected for local chat also. You want to put this script into player.lua under gamemode:PlayerCanSeePlayersChat(). Now to all you experienced lua scripters out there, I know this could probably be shortened, but it works, so I'm happy with it.

    Code:
    --[[---------------------------------------------------------
       Name: gamemode:PlayerCanSeePlayersChat()
    		Can this player see the other player's chat?
    -----------------------------------------------------------]]
    function GM:PlayerCanSeePlayersChat( strText, bTeamOnly, pListener, pSpeaker )
    	
    	/*if ( bTeamOnly ) then
    		if ( !IsValid( pSpeaker ) || !IsValid( pListener ) ) then return false end
    		if ( pListener:Team() != pSpeaker:Team() ) then return false end
    	end*/
    	if bTeamOnly then return true end
    	if (pSpeaker:GetLocationName() == "Lobby" or 
    	pSpeaker:GetLocationName() == "Left Wing" or
    	pSpeaker:GetLocationName() == "Right Wing" or
    	pSpeaker:GetLocationName() == "Men's Bathroom" or
    	pSpeaker:GetLocationName() == "Women's Bathroom" or
    	pSpeaker:GetLocationName() == "Concessions") and (pListener:GetLocationName() == "Lobby" or 
    	pListener:GetLocationName() == "Left Wing" or
    	pListener:GetLocationName() == "Right Wing" or
    	pListener:GetLocationName() == "Men's Bathroom" or
    	pListener:GetLocationName() == "Women's Bathroom" or
    	pListener:GetLocationName() == "Concessions") then return true end
    	
    	if pSpeaker:GetLocation() != pListener:GetLocation() then return false end
    	
    	return true
    	
    end

  11. Post #251
    YukiTheater.org
    WinterPhoenix's Avatar
    January 2013
    28 Posts
    I saw some people ask for a local chat system where players don't see local chat between theaters. Now I am not very experienced in lua yet, but I'm learning and I managed to make a system that works. This chat will make all theaters local chat be only within the theater itself and all the of lobby locations are connected for local chat also. You want to put this script into player.lua under gamemode:PlayerCanSeePlayersChat(). Now to all you experienced lua scripters out there, I know this could probably be shortened, but it works, so I'm happy with it.

    Code:
    --[[---------------------------------------------------------
       Name: gamemode:PlayerCanSeePlayersChat()
    		Can this player see the other player's chat?
    -----------------------------------------------------------]]
    function GM:PlayerCanSeePlayersChat( strText, bTeamOnly, pListener, pSpeaker )
    	
    	/*if ( bTeamOnly ) then
    		if ( !IsValid( pSpeaker ) || !IsValid( pListener ) ) then return false end
    		if ( pListener:Team() != pSpeaker:Team() ) then return false end
    	end*/
    	if bTeamOnly then return true end
    	if (pSpeaker:GetLocationName() == "Lobby" or 
    	pSpeaker:GetLocationName() == "Left Wing" or
    	pSpeaker:GetLocationName() == "Right Wing" or
    	pSpeaker:GetLocationName() == "Men's Bathroom" or
    	pSpeaker:GetLocationName() == "Women's Bathroom" or
    	pSpeaker:GetLocationName() == "Concessions") and (pListener:GetLocationName() == "Lobby" or 
    	pListener:GetLocationName() == "Left Wing" or
    	pListener:GetLocationName() == "Right Wing" or
    	pListener:GetLocationName() == "Men's Bathroom" or
    	pListener:GetLocationName() == "Women's Bathroom" or
    	pListener:GetLocationName() == "Concessions") then return true end
    	
    	if pSpeaker:GetLocation() != pListener:GetLocation() then return false end
    	
    	return true
    	
    end
    I did this a while ago actually, Sam just never merged the Pull Request.

  12. Post #252
    kpjVideo's Avatar
    March 2013
    156 Posts
    Sorry for the bump, but it seems the furniture in the official map (Cinema_Theatron) are errors. Things such as lightswitches, tables, chairs etc. Any ideas? Thanks

  13. Post #253
    -snip-
    code_gs's Avatar
    March 2013
    7,451 Posts
    Sorry for the bump, but it seems the furniture in the official map (Cinema_Theatron) are errors. Things such as lightswitches, tables, chairs etc. Any ideas? Thanks
    The models come with the workshop version.

  14. Post #254
    YukiTheater.org
    WinterPhoenix's Avatar
    January 2013
    28 Posts
    Sorry for the bump, but it seems the furniture in the official map (Cinema_Theatron) are errors. Things such as lightswitches, tables, chairs etc. Any ideas? Thanks
    Those models are not packed into the .BSP File for whatever reason. You'll need to get them from the Workshop version.

  15. Post #255
    GM Servers - Social Manager/Public Relations
    FyllyMan's Avatar
    October 2012
    78 Posts
    Hey how do you add entities to the map? With the gamemode files? Like pool tables or slot machines (trying to add the ones from elevator source)

    Want to add some stuff for people to do when not watching films.

    Also I had a question, is it possible to set up scheduled videos in theaters? To make it load a url at a certain time, so you could in theory set up schedules.

  16. Post #256

    April 2014
    1 Posts
    Hi guys, is there any way to remove the ambient noise on the cinema_theatron maps? It's really loud, even with the volume at 100. Right now I just alt+tab with the "Mute audio while alttabbed" unchecked, but I would like to know if there's a better solution.

  17. Post #257
    SWAG KING 2014
    Lebofly's Avatar
    November 2008
    656 Posts
    Hi guys, is there any way to remove the ambient noise on the cinema_theatron maps? It's really loud, even with the volume at 100. Right now I just alt+tab with the "Mute audio while alttabbed" unchecked, but I would like to know if there's a better solution.
    Lower the actually game audio