1. Post #1
    irontires's Avatar
    May 2011
    117 Posts
    Armored Combat Framework (ACF)


    NEW THREAD: http://facepunch.com/showthread.php?t=1244349





    --Wrex
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Winner Winner x 6Lua King Lua King x 4Useful Useful x 2Friendly Friendly x 1 (list)

  2. Post #2
    Diehard55's Avatar
    May 2010
    61 Posts
    So when I install ACF, I just put it in the addons folder just like on Gmod 12 right?
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Dumb Dumb x 2Winner Winner x 1 (list)

  3. Post #3
    irontires's Avatar
    May 2011
    117 Posts
    So when I install ACF, I just put it in the addons folder just like on Gmod 12 right?
    Yeppers, make sure to move Particles and Scripts to the garrysmodbeta folder from the addon folder you make.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Lua King Lua King x 1 (list)

  4. Post #4
    Diehard55's Avatar
    May 2010
    61 Posts
    Yeppers, make sure to move Particles and Scripts to the garrysmodbeta folder from the addon folder you make.
    Alright, cool! But another quick question, where exactly do I find Wiremod? I tried to google it for gmod 13 already but I can't seem to find it?

    Edited:

    Thanks man!

  5. Post #5
    irontires's Avatar
    May 2011
    117 Posts
    Alright, cool! But another quick question, where exactly do I find Wiremod? I tried to google it for gmod 13 already but I can't seem to find it?
    -sniped old link-
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Friendly Friendly x 1Funny Funny x 1 (list)

  6. Post #6
    Needs more suspension.
    Dennab
    February 2006
    4,484 Posts
    holy fuck this guy tingles just comes out of nowhere, LOL FIXED ACF FOR GM13

    holy balls lol
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Informative Informative x 2Lua Helper Lua Helper x 1Dumb Dumb x 1 (list)

  7. Post #7
    irontires's Avatar
    May 2011
    117 Posts
    holy fuck this guy tingles just comes out of nowhere, LOL FIXED ACF FOR GM13

    holy balls lol
    off topic ^.^
    Damnit Karb! Contaminating this thread with balls!


    and yes tingle got the base working great, I only had to change a few things to get everything else working, instead of changing the entire codebase, heh.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Agree Agree x 1 (list)

  8. Post #8
    Needs more suspension.
    Dennab
    February 2006
    4,484 Posts
    didn't know you and kaf also fixed it, awesome work with that
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Dumb Dumb x 1 (list)

  9. Post #9
    Frankess's Avatar
    November 2005
    511 Posts
    If you are going to release it on Workshop then could you change every folder and file name in "lua" to lowercase, so linux server also could have it?
    Reply With Quote Edit / Delete Reply Windows 7 Poland Show Events Agree Agree x 3 (list)

  10. Post #10
    irontires's Avatar
    May 2011
    117 Posts
    If you are going to release it on Workshop then could you change every folder and file name in "lua" to lowercase, so linux server also could have it?

    We'll look into that for you :)
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Friendly Friendly x 1Agree Agree x 1 (list)

  11. Post #11
    Uberpro's Avatar
    January 2010
    829 Posts
    I'm not sure if this is the correct thread to post this, but isn't gas turbine supposed to create forward thrust for itself, instead of having to link it to a gearbox and using it to rotate wheels etc..

    Edited:

    Or am I doing something wrong?
    Reply With Quote Edit / Delete Reply Windows 7 Finland Show Events Disagree Disagree x 1Agree Agree x 1 (list)

  12. Post #12
    irontires's Avatar
    May 2011
    117 Posts
    I'm not sure if this is the correct thread to post this, but isn't gas turbine supposed to create forward thrust for itself, instead of having to link it to a gearbox and using it to rotate wheels etc..

    Edited:

    Or am I doing something wrong?
    Nope, its for wheel power.

    I was thinking of making some spacebuild style engines

    Like a main engine that you would link special thrusters to, that run on fuel. It would be a seperate addon though, not part of the original acf install.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Lua King Lua King x 1Agree Agree x 1 (list)

  13. Post #13
    Nope, its for wheel power.

    I was thinking of making some spacebuild style engines

    Like a main engine that you would link special thrusters to, that run on fuel. It would be a seperate addon though, not part of the original acf install.
    I remember things like that from SB2, part of petrol and gas addons for LS2, it was brilliant!

    Do it!
    Reply With Quote Edit / Delete Reply Windows 7 Sweden Show Events Optimistic Optimistic x 2Agree Agree x 1 (list)

  14. Post #14
    Gold Member
    Pigbear's Avatar
    September 2011
    1,946 Posts
    Nope, its for wheel power.

    I was thinking of making some spacebuild style engines

    Like a main engine that you would link special thrusters to, that run on fuel. It would be a seperate addon though, not part of the original acf install.
    I would use that. I think a lot of people would.
    Reply With Quote Edit / Delete Reply Windows XP United States Show Events Agree Agree x 2 (list)

  15. Post #15
    Dennab
    June 2010
    2,040 Posts
    Can we get the old 6pdr muzzleloader back?
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Disagree Disagree x 2Agree Agree x 1 (list)

  16. Post #16
    Oh yeah and fix your casing, stop using mixed lower/uppercase and make sure it's CORRECT everywhere, makes for a huge pain in the ass for any linux server owners.

    Reply With Quote Edit / Delete Reply Windows 7 Sweden Show Events Agree Agree x 2 (list)

  17. Post #17

    January 2012
    43 Posts
    How exactly do I install this? And will this ever be on Workshop?
    Reply With Quote Edit / Delete Reply Mac Sweden Show Events Funny Funny x 1 (list)

  18. Post #18
    Frankess's Avatar
    November 2005
    511 Posts
    The update is out. I think it's good time to change names to lowercase. If you want I can change it for you and send it back - it's nothing hard (but it takes time).

  19. Post #19

    October 2012
    7 Posts
    What folder do I install the wiremod folder into, and also for the ACF Mod, if I'm running gmod 13 and not the beta, do I just put it in garrysmod/garrysmod?

  20. Post #20
    irontires's Avatar
    May 2011
    117 Posts
    https://github.com/wiremod/wire.git/branches/master < direct linking wont work, has to be svn client

    install to garrysmod/garrysmod/addons/ just like before.

  21. Post #21
    I'm a greedy asshole.
    FLIPPY's Avatar
    April 2008
    756 Posts
    Dont forget to rename info.txt addon.txt. SOME FUCKING INFO LIKE THAT FROM THE OP WOULD BE NICE.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Lua King Lua King x 1Lua Helper Lua Helper x 1 (list)

  22. Post #22

    October 2012
    7 Posts
    I got the wiremod working, now to get the ACF working, thanks for this :)
    (edit) - Also, I was wondering where to put the ACF, it says to put the folder into addons, then the Scripts and particles folders go into the main Gmod directory, so I go garrysmod/garrysmod and place them into the 2nd garrysmod folder correct?

  23. Post #23
    irontires's Avatar
    May 2011
    117 Posts
    Dont forget to rename info.txt addon.txt. SOME FUCKING INFO LIKE THAT FROM THE OP WOULD BE NICE.
    Will be fixed in the next ACF update. Adding to OP now, heh.

  24. Post #24
    Recon_117's Avatar
    July 2006
    7 Posts
    For some reason i get this:

    ACF Loaded
    Attemped to precache unknown particle system "tracer_tail_white"!
    Attemped to precache unknown particle system "tracer_tail_white"!
    Checking for updates....
    --- Missing Vgui material texturemissing

    [ERROR] addons/acf/lua/effects/acf_tracer/init.lua:23: invalid escape sequence near '"sprites'
    1. unknown - addons/acf/lua/effects/acf_tracer/init.lua:0

  25. Post #25
    irontires's Avatar
    May 2011
    117 Posts
    For some reason i get this:

    ACF Loaded
    Attemped to precache unknown particle system "tracer_tail_white"!
    Attemped to precache unknown particle system "tracer_tail_white"!
    Checking for updates....
    --- Missing Vgui material texturemissing

    [ERROR] addons/acf/lua/effects/acf_tracer/init.lua:23: invalid escape sequence near '"sprites'
    1. unknown - addons/acf/lua/effects/acf_tracer/init.lua:0

    Also will be fixed in the next update :)

  26. Post #26
    Recon_117's Avatar
    July 2006
    7 Posts
    thank you
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Winner Winner x 1 (list)

  27. Post #27

    October 2012
    7 Posts
    Also will be fixed in the next update :)
    Sweet! I was also getting this problem, Thanks for the fix!! :)
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Agree Agree x 1 (list)

  28. Post #28
    irontires's Avatar
    May 2011
    117 Posts
    Right now I'm trying to figure out whats up with PrecacheParticleSystem()

    It just errors no matter what and they're not answering my post in help and support!


    http://facepunch.com/showthread.php?t=1220616

    Edited:

    Fixed the tracer lua error and renamed info.txt to addon.txt waiting for Kaf to accept the pull.

    Apparently PrecacheParticleSystem() has always error-ed like that so just ignore it for now.


    I will start working on fixing the casing. I have alot on my plate right now so it probably wont be till tomorrow.

  29. Post #29

    January 2012
    43 Posts
    How?

    I got the wiremod working, now to get the ACF working, thanks for this :)

  30. Post #30
    irontires's Avatar
    May 2011
    117 Posts
    Tracer fixed and info.txt renamed, updated OP.

    Edited:


    Whats wrong?

  31. Post #31

    January 2012
    43 Posts
    I don't really understand how to install this, do I need to download the SVN and have Wire. I tried changing the info.txt after installing it as I would do in GMod 12. Didn't work.
    Tracer fixed and info.txt renamed, updated OP.

    Edited:




    Whats wrong?

  32. Post #32
    Gold Member
    Jeffman12's Avatar
    July 2005
    467 Posts
    Should info.txt be named addon.txt now? I just got the SVN version and it didn't seem to work.
    ^That did it.

    So, now "Ready"(To fire) seems faulty, I'm using a 20mm AC to do some testing. It reports as 1 even when the weapon is not loaded.
    I need to hold down the button to set ammo as active for it to fire more than one shot, and the number of shots it will fire is set to 30, but it only depletes if I don't let go of the mouse button at all before all 30 deplete. I've taken to labeling that latter as "heat" instead of rounds left, as it seems to work better under that description.

    Actually, scratch that last part, this is sort of weird: I need to designate an ammo as active for the weapon to load it, this makes sense the first time, but as is makes having a reload key unnecessary, but as is, the reload key doesn't seem to work, so to fire repeatedly, I must hold down the button to designate an ammo type as active if I wish to sustain fire. Good thing I wired it to mouse 2.

    I started with a basic testing setup

    Chair, pod controller, gun, ammo crate.
    The gun is set to a display to show when it can fire and how many rounds are loaded, allegedly 30, but I can't fire them in sequence without holding down mouse2 while clicking/holding down mouse1 to fire.
    Reply With Quote Edit / Delete Reply Windows 7 United States Show Events Winner Winner x 1 (list)

  33. Post #33
    irontires's Avatar
    May 2011
    117 Posts
    Should info.txt be named addon.txt now? I just got the SVN version and it didn't seem to work.
    ^That did it.

    So, now "Can Fire" seems faulty, I'm using a 20mm AC to do some testing. It reports as 1 even when the weapon is not loaded.
    I need to hold down the button to set ammo as active for it to fire more than one shot, and the number of shots it will fire is set to 30, but it only depletes if I don't let go of the mouse button at all before all 30 deplete. I've taken to labeling that latter as "heat" instead of rounds left, as it seems to work better under that description.
    Could you make a new issue for this on the github page? Not all the devs watch the thread :)

    If any other issues could be posted on the Github page I would really appreciate it. :D


    Edit:
    Active really should be on a Toggled output :)

  34. Post #34

    September 2012
    1 Posts

    **THIS WILL NEVER BE ON THE WORKSHOP DUE TO WIREMOD HAVING INCOMPATIBLE LICENSES WITH VALVE'S WORKSHOP**
    http://steamcommunity.com/sharedfile.../?id=104622994
    (paste into in game browser, will not be found otherwise)

  35. Post #35
    irontires's Avatar
    May 2011
    117 Posts
    http://steamcommunity.com/sharedfile.../?id=104622994
    (paste into in game browser, will not be found otherwise)

    He had permission to upload the models/sounds/materials :)

  36. Post #36
    FeelAFear's Avatar
    October 2012
    3 Posts
    Following this forum, I can't seem to get the sound or effects/Particles working.
    I'm using the latest versions of Wire mod's SVN and ACF's SVN, I have moved the Scripts and particle folders to Garrysmod/Garrysmod. I even tried putting the ACF SVN in Garrysmod/garrysmod, tried making its own folder in addons and tried putting all the folders into addons.

    The mod itself works in game, the ACFmenu is there and I can spawn and wire everything fine; But theres no effects or sounds whatso ever.

    What am I doing wrong here? x3

  37. Post #37
    irontires's Avatar
    May 2011
    117 Posts
    Following this forum, I can't seem to get the sound or effects/Particles working.
    I'm using the latest versions of Wire mod's SVN and ACF's SVN, I have moved the Scripts and particle folders to Garrysmod/Garrysmod. I even tried putting the ACF SVN in Garrysmod/garrysmod, tried making its own folder in addons and tried putting all the folders into addons.

    The mod itself works in game, the ACFmenu is there and I can spawn and wire everything fine; But theres no effects or sounds whatso ever.

    What am I doing wrong here? x3

    That's really strange :O, They should be working, however I did find out that my game volume was 0 after the update at first ^.^.

  38. Post #38
    FeelAFear's Avatar
    October 2012
    3 Posts
    I got it to make the sounds and Muzzle flash of the gun shooting, But theres still no impact effects or any indication of where its hitting.. No tracers either.
    This is an Error I found in the Console, Hope it helps?

    ACF Loaded
    Checking for updates....
    Couldn't include file 'includes\modules\glon.lua' (File not found) (<nowhere>)
    ACF Is Up To Date, Latest Version: 324
    Garry's Mod
    http://loading.garrysmod.com/
    sandbox
    gm_flatgrass
    1
    76561197994455733
    Attemped to precache unknown particle system "error"!
    Attemped to precache unknown particle system "tracer_tail_white"!
    Attemped to precache unknown particle system "generic_smoke"!
    Attemped to precache unknown particle system "blood_impact_red_01"!
    Attemped to precache unknown particle system "blood_impact_green_01"!
    Attemped to precache unknown particle system "blood_impact_yellow_01"!
    Attemped to precache unknown particle system "burning_character"!
    Attemped to precache unknown particle system "slime_splash_01"!
    Attemped to precache unknown particle system "slime_splash_02"!
    Attemped to precache unknown particle system "slime_splash_03"!
    Requesting 5 lua files from the server
    Warning: WorldTwoTextureBlend found on a non-displacement surface (material: gm_construct/flatgrass). This wastes perf for no benefit.
    clientside lua startup!
    ACF Loaded
    Attemped to precache unknown particle system "tracer_tail_white"!
    Attemped to precache unknown particle system "tracer_tail_white"!
    Checking for updates....
    Requesting texture value from var "$dummyvar" which is not a texture value (material: NULL material)
    --- Missing Vgui material texturemissing

    [ERROR] addons/acf/lua/effects/acf_tracer/init.lua:23: invalid escape sequence near '"sprites'
    1. unknown - addons/acf/lua/effects/acf_tracer/init.lua:0

    ACF Is Up To Date, Latest Version: 324
    R

  39. Post #39

    October 2012
    7 Posts
    Now that I have everything working, My wheels fall under the ground due to too much torque, is there a way to stop it from doing that, like MakeSpherical or something, I can't even find the download for the sphereical tool

  40. Post #40
    irontires's Avatar
    May 2011
    117 Posts
    Now that I have everything working, My wheels fall under the ground due to too much torque, is there a way to stop it from doing that, like MakeSpherical or something, I can't even find the download for the sphereical tool

    I have a version that I converted.

    I could pm you the link if you wish to use it, but I heard falqn was going to fix the official one.

    Edited:

    I got it to make the sounds and Muzzle flash of the gun shooting, But theres still no impact effects or any indication of where its hitting.. No tracers either.
    This is an Error I found in the Console, Hope it helps?

    ACF Loaded
    Checking for updates....
    Couldn't include file 'includes\modules\glon.lua' (File not found) (<nowhere>)
    ACF Is Up To Date, Latest Version: 324
    Garry's Mod
    http://loading.garrysmod.com/
    sandbox
    gm_flatgrass
    1
    76561197994455733
    Attemped to precache unknown particle system "error"!
    Attemped to precache unknown particle system "tracer_tail_white"!
    Attemped to precache unknown particle system "generic_smoke"!
    Attemped to precache unknown particle system "blood_impact_red_01"!
    Attemped to precache unknown particle system "blood_impact_green_01"!
    Attemped to precache unknown particle system "blood_impact_yellow_01"!
    Attemped to precache unknown particle system "burning_character"!
    Attemped to precache unknown particle system "slime_splash_01"!
    Attemped to precache unknown particle system "slime_splash_02"!
    Attemped to precache unknown particle system "slime_splash_03"!
    Requesting 5 lua files from the server
    Warning: WorldTwoTextureBlend found on a non-displacement surface (material: gm_construct/flatgrass). This wastes perf for no benefit.
    clientside lua startup!
    ACF Loaded
    Attemped to precache unknown particle system "tracer_tail_white"!
    Attemped to precache unknown particle system "tracer_tail_white"!
    Checking for updates....
    Requesting texture value from var "$dummyvar" which is not a texture value (material: NULL material)
    --- Missing Vgui material texturemissing

    [ERROR] addons/acf/lua/effects/acf_tracer/init.lua:23: invalid escape sequence near '"sprites'
    1. unknown - addons/acf/lua/effects/acf_tracer/init.lua:0

    ACF Is Up To Date, Latest Version: 324
    R
    You didn't click on the SVN link I provided up in the OP right? I fixed the invalid escape sequence error yesterday. You have to copy and paste the link directly into your SVN client, or it will load the original branch that's outdated.

    As for the precache errors, dont worry about those.